Strange problem with process group and zend opcache

Discussion in 'Install/Configuration' started by bettinz, Mar 17, 2014.

  1. bettinz

    bettinz Member

    Hello, I've a curious problem.
    I'm using litespeed 4.2.7, php 5.5.10 and zend opcache.
    So, If i use the suexec daemon, and I save my php.ini with that settings:
    Code:
    zend_extension=opcache.so
    opcache.memory_consumption=32
    opcache.interned_strings_buffer=8
    opcache.max_accelerated_files=4000
    opcache.revalidate_freq=180
    opcache.fast_shutdown=0
    opcache.enable_cli=0
    opcache.save_comments=0
    opcache.enable_file_override=1
    and in pre_virtualhost_global.conf
    Code:
    <IfModule LiteSpeed>
    LSPHP_ProcessGroup off
    LSPHP_Workers 10
    </IfModule>
    in my php info I can see zend opcache running. So far, so good. Now If I set
    Code:
    <IfModule LiteSpeed>
    LSPHP_ProcessGroup on
    LSPHP_Workers 10
    </IfModule>
    In my php info I can't see zend opcache running (it's not loaded at all). What I'm missing?
    Thank you
  2. NiteWave

    NiteWave Administrator

  3. bettinz

    bettinz Member

    I've solved by changing
    Run On Start Up
    to NO. It's strange because the documentation said that process group override this setting, but if anyone find this problem the solution maybe is that. Other settings are ok, and the php.ini is the same /usr/local/lib/php.ini with process_group on or off

Share This Page