Upgrade to PHP 5.4.6 failed

Discussion in 'PHP' started by theRKF, Aug 18, 2012.

  1. theRKF

    theRKF Member

    I was running 5.3.15 and debating between moving to 5.3.16 or 5.4.6, so I thought I'd try both.

    5.3.16 went without a problem.

    On the other hand, as soon as I switched the symlink to point to the 5.4.6 version of PHP all sites ceased to load - even with a restart of LiteSpeed.

    Is there any known compatibility issue with LiteSpeed 4.1.13 and PHP 5.4.6?

    FYI: Here's my configure command, in case the settings matter
    Code:
    './configure' '--prefix=/usr/local' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-magic-quotes' '--enable-pdo=shared' '--enable-sockets' '--enable-zip' '--with-curl=/opt/curlssl/' '--with-freetype-dir=/usr' '--with-gd' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-mysqli=/usr/bin/mysql_config' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-pic' '--with-png-dir=/usr' '--with-sqlite=shared' '--with-xpm-dir=/usr' '--with-zlib' '--with-zlib-dir=/usr' '--with-litespeed' '--enable-mbstring' '--with-xmlrpc' '--enable-soap' '--enable-intl' '--enable-suhosin'
  2. webizen

    webizen New Member

    5.3 and 5.4 don't share the same php.ini which is likely the cause of the issue. you need to check error log and stderr.log to see any error.

Share This Page