Using not all hardware speed

Discussion in 'Install/Configuration' started by GiedriusQ, Jan 22, 2012.

  1. GiedriusQ

    GiedriusQ New Member

    Hello,

    First of all I want to say hello to everyone in this forum and sorry if I posted my thread in wrong section.

    Ok, now about my "problem".
    Currently my server running on:
    Intel Q6600 processor (4core/4th/2,4Ghz/8Mb L2)
    8GB of RAM
    3x120GB SSD (2 in software raid0, mounted on /files/ )
    1Gbps network.
    Debian Linux
    2Core lite license.

    Internet speed (IN) are around 200-300Mbps, OUT: 150-200Mbps
    I think it's quiet too slow for such fast disk[?].
    I'm using moded rapidleech script, so in fact it just read data from external sites and write data to files (located in /files/), then serve files to users. In one word, work with files.

    So in my opinion something wrong with litespeed server settings, because speed is too low, IO sometimes gets very high, maybe someone can help me?

    All my configuration and real-time stats:http://imageshack.us/g/194/muninq.png/
  2. NiteWave

    NiteWave Administrator

    please paste output
    #top -c
  3. GiedriusQ

    GiedriusQ New Member

    Code:
    root@52585:~# top -c
    top - 17:53:48 up 11 days, 14:26,  1 user,  load average: 1.69, 1.27, 1.29
    Tasks: 207 total,   2 running, 204 sleeping,   0 stopped,   1 zombie
    Cpu(s): 11.2%us, 19.2%sy,  0.0%ni, 58.5%id,  1.5%wa,  0.4%hi,  9.2%si,  0.0%st
    Mem:   8188092k total,  8136972k used,    51120k free,    15176k buffers
    Swap: 14115832k total,    21432k used, 14094400k free,  7202876k cached
    
      PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
    19385 mysql     20   0  326m  36m 2940 S   96  0.5   1589:53 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --pid-file=/var/run/mysqld/mysqld.pid
    22246 proxy     20   0 39016  19m 1424 S   13  0.2  77:48.11 (squid) -D -YC
    17343 nobody     1 -19 95424 9488 3636 R    3  0.1   0:08.64 lsphp5:/home/<...>/index.php
    17339 nobody     1 -19 95424 9652 3688 S    3  0.1   0:05.12 lsphp5:/home/<...>/index.php
    16163 nobody     1 -19 95024 9508 3640 S    2  0.1   0:06.44 lsphp5
     7957 nobody     1 -19  125m  23m 5152 S    2  0.3  30:57.43 litespeed (lshttpd)
    15142 nobody     1 -19 95428 9572 3684 S    2  0.1   0:07.36 lsphp5:/home/<...>/index.php
    16031 nobody     1 -19 97880  11m 3608 S    2  0.1   0:04.24 lsphp5:/home/<...>/index.php
    18291 nobody     1 -19 97892  11m 3608 S    2  0.1   0:00.65 lsphp5:/home/<...>/index.php
       47 root      20   0     0    0    0 S    1  0.0  57:18.83 [kswapd0]
     7956 nobody     1 -19  122m  18m 3216 S    1  0.2  21:28.09 litespeed (lshttpd)
    17006 nobody     1 -19 95280 9284 3556 S    1  0.1   0:07.07 lsphp5:/home/<...>/index.php
    17189 nobody     1 -19 96700  10m 3584 S    1  0.1   0:06.22 lsphp5:/home/<...>/index.php
     1057 nobody     1 -19 95424 9564 3652 S    1  0.1   0:15.84 lsphp5:/home/<...>/index.php
    18798 nobody     1 -19 95684 9864 3652 S    1  0.1   0:05.00 lsphp5:/home/<...>/index.php
    20069 nobody     1 -19 96564 9744 3312 S    1  0.1   0:00.13 lsphp5
     2081 nobody     1 -19 98020  11m 3668 S    1  0.1   0:15.13 lsphp5:/home/<...>/index.php
     4449 nobody     1 -19 96560  10m 3672 S    1  0.1   0:16.31 lsphp5:/home/<...>/index.php
     7432 nobody     1 -19 99120  13m 3624 S    1  0.2   0:35.67 lsphp5:/home/<...>/index.php
    10969 nobody     1 -19 95536 9988 3628 S    1  0.1   0:11.04 lsphp5:/home/<...>/index.php
    17669 nobody     1 -19 96960  10m 3628 S    1  0.1   0:02.92 lsphp5:/home/<...>/index.php
    18799 nobody     1 -19 95324 9568 3628 S    1  0.1   0:03.23 lsphp5:/home/<...>/index.php
    18802 nobody     1 -19 96960  10m 3672 S    1  0.1   0:02.24 lsphp5:/home/<...>/index.php
        4 root      20   0     0    0    0 S    0  0.0   5:09.72 [ksoftirqd/0]
     2899 nobody     1 -19 95424 9504 3640 S    0  0.1   0:18.62 lsphp5:/home/<...>/index.php
     4267 nobody     1 -19 95424 9448 3628 S    0  0.1   0:12.63 lsphp5:/home/<...>/index.php
    11352 nobody     1 -19 95680 9844 3652 S    0  0.1   0:09.96 lsphp5:/home/<...>/index.php
    13720 root      20   0 72388  24m 1464 S    0  0.3   0:00.91 lfd - sleeping
    14752 nobody     1 -19 95424 9464 3640 S    0  0.1   0:04.14 lsphp5:/home/<...>/index.php
    18492 nobody     1 -19 95172 9288 3632 S    0  0.1   0:04.26 lsphp5
    20064 root      20   0 19168 1432  996 R    0  0.0   0:00.06 top -c
        1 root      20   0  8352  524  460 S    0  0.0   0:07.06 init [2]
        2 root      20   0     0    0    0 S    0  0.0   0:00.00 [kthreadd]
        3 root      RT   0     0    0    0 S    0  0.0   0:02.96 [migration/0]
        5 root      RT   0     0    0    0 S    0  0.0   0:00.00 [watchdog/0]
        6 root      RT   0     0    0    0 S    0  0.0   0:03.02 [migration/1]
        7 root      20   0     0    0    0 S    0  0.0   1:18.84 [ksoftirqd/1]
  4. GiedriusQ

    GiedriusQ New Member

    And there is another problem, after sometime server OUT speed become very very low. Sometimes IN speed also lowers...
    When using nginx for file serve such problem with speed changes to very low never shows up.
    Last edited: Jan 26, 2012
  5. webizen

    webizen New Member

    Your throughput is not necessarily slow given your 1Gbps network. It depends on what kind of file (smaller files lower the bandwidth usage due to TCP overhead) you serve and where the bottleneck is.

    From the 'top -c' screenshot, looks like I/O is not the bottleneck. server load is not high. Real-time stats show you only have less than http 1000 connections used. However, your lsphp5 has max connection of 1000 which is too high. It should be set to 100~150 (in your case). so is the PHP_LSAPI_CHILDREN variable.
  6. GiedriusQ

    GiedriusQ New Member

    I did what You say, but nothing changed.
    For example by internet max speed is 500KB/s. When I'm download file from server I get only ~100-200KB/s, but when using nginx and download same file I get all my 500KB/s all the time.
    I think something really wrong with my litespeed server settings, but I can't find out what...

Share This Page