Using Ruby on Rails with LSWS Enterprise 4.0.11?

Discussion in 'Install/Configuration' started by MikeDVB, Oct 8, 2009.

  1. MikeDVB

    MikeDVB New Member

    I'm trying to get this set up for a client but I keep hitting dead ends. If anybody out there using RoR in a shared environment for a client would like to lend a hand/give some advice I would greatly appreciate it :)
  2. mistwang

    mistwang LiteSpeed Staff

  3. MikeDVB

    MikeDVB New Member

    This is working nice as long as you don't use a symlink to point to your application.

    If you set the app path as /public_html/theapp - and the files are actually in that folder it works. If you set the path as /public_html/theapp/current and that is a symlink to somewhere else (such as /public_html/theapp/1251231231/) it will fail with a 503 error.

    Does LSWS not follow SymLinks when following the directives in a .ls_rails_config file?

    I have managed to get it working I think with a relative symlink but the thing is that if that symlink changes LSWS doesn't pick up on it unless you restart LSWS - or that's how it seems.
    Last edited: Oct 12, 2009
  4. MikeDVB

    MikeDVB New Member

    Here is the .ls_rails_config:
    Code:
    RailsApp tcl_beta_site "/public_html/beta" "Production" 2 1
    
    RailsAppMap tcl_beta_site "test2.thecliplady.com" "/"
    
    Here is the error:
    Code:
    2009-10-12 19:05:55.060 [INFO] [HTAccess] Updating configuration from [/home/theclipl/public_html/beta/public/.htaccess]
    2009-10-12 19:05:55.060 [ERROR] [config] Path for Rails application is invalid: /home/theclipl/etc/rails_apps/test/
    For some reason it's still trying to access /etc/rails_apps/test/ instead of the file specified. I thought that maybe updating the path that was set in the cPanel for that subdomain to the correct path would do it but it seems that LSWS is not over-riding the httpd.conf settings for this rails app:

    Code:
    2009-10-12 19:08:50.586 [INFO] [xx.xx.xx.xx:58404-1#APVH_test2.thecliplady.com] Auto Index is disabled for [/home/theclipl/public_html/beta/public/], access denied
    2009-10-12 19:08:50.068 [INFO] [xx.xx.xx.xx:58404-0#APVH_test2.thecliplady.com] Auto Index is disabled for [/home/theclipl/public_html/beta/public/], access denied
    2009-10-12 19:08:44.546 [INFO] [xx.xx.xx.xx:33038-0#APVH_test2.thecliplady.com] Auto Index is disabled for [/home/theclipl/public_html/beta/public/], access denied
  5. mistwang

    mistwang LiteSpeed Staff

    Can it be fixed by restarting LSWS?
    LSWS resolve symbolic link when read configuration, but does not update the link if changed. Will have it addressed in 4.1 release branch.
  6. MikeDVB

    MikeDVB New Member

    Yeah, but we were having some other funny issues - I'm more than happy to set you up with an account so you can do some testing if you want or to get you in touch with the guy who was doing the Ruby things if you wish.

Share This Page