/usr/bin/mailx: invalid option -- b

Discussion in 'Bug Reports' started by munduk75, Sep 9, 2009.

  1. munduk75

    munduk75 New Member

    Hi,

    Under Debian I cannot get LS to send an email when a new release is available.

    OS : Debian Lenny 64 bits
    LSWS : 4.0.8 Standard

    - error msg :
    Code:
    2009-08-20 19:43:50.848 [STDERR] /usr/bin/mailx: invalid option -- b
    2009-08-20 19:43:50.876 [STDERR] Try `mailx --help' or `mailx --usage' for more information.
    - mail/mailx :

    Code:
    # mailx --version
    mail (GNU Mailutils 1.2)
    
    
    # mailx --help
    Usage: mailx [OPTION...] [address...]
    GNU mail -- the standard /usr/bin/mail interface
    
      -a, --append=HEADER: VALUE Append given header to the message being sent
      -e, --exist                Return true if mail exists
      -E, --exec=COMMAND         Execute COMMAND
      -f, --file[=URL]           Operate on given mailbox URL (default ~/mbox)
      -F, --byname               Save messages according to sender
      -H, --headers              Write a header summary and exit
      -i, --ignore               Ignore interrupts
      -n, --norc                 Do not read the system mailrc file
      -N, --nosum                Do not display initial header summary
      -p, --print                Print all mail to standard output
      -q, --quit                 Cause interrupts to terminate program
      -r, --read                 Same as -p
      -s, --subject=SUBJ         Send a message with a Subject of SUBJ
      -t, --to                   Precede message by a list of addresses
      -u, --user=USER            Operate on USER's mailbox
    
  2. auser

    auser Super Moderator

    your mailx is not the default one for Debian. Below is from my Debian:
    Code:
    # mailx --help
    mailx: invalid option -- -
    usage: mailx [-eIinv] [-a header] [-b bcc-addr] [-c cc-addr] [-s subject]
                 to-addr [...] [-- sendmail-options [...]]
           mailx [-eIiNnv] -f [name]
           mailx [-eIiNnv] [-u user]
    #
    # aptitude install mailx

    will install the default mailx.
  3. munduk75

    munduk75 New Member

    I don't know why the GNU one was installed by default.
    Anyway, it works now thanks.

Share This Page