VIRTUAL HOST PATH permissions

Discussion in 'Install/Configuration' started by gcaplan, Nov 11, 2010.

  1. gcaplan

    gcaplan New Member

    Hi folks

    Trying to set up a VIRTUAL HOST PATH in the console, and getting "path not writeable" errors. There's obviously something basic I'm not understanding...

    LS is running on CentOS, as apache. I can save paths down to /var/www/, which are owned by root. I can't save any paths below this, whether owned by root or by apache. Owner has rwx permissions on all directories in path.

    Adding to my confusion: I have other VHosts working fine with host and document paths which the console is telling me aren't writeable.

    I guess I'm doing something dumb here, but it's been a long day and I can't figure out what it is...

    PS: recently re-compiled php, via the console, if that's relevant.
    Last edited: Nov 11, 2010
  2. gcaplan

    gcaplan New Member

    I've solved this by writing the doc path directly in the xml config file, but I would still appreciate any help as to why I can't do this in the console.
  3. webizen

    webizen New Member

    lsws_server_root/conf/* (including conf directory itself) should be owned by lsadm user so that web console can update xml config file there. vhost path needs to be created manually as instructed on console page (adding vhost):
    ------>8-------
    All directories must preexist. This web interface will not create directory for you. If you are creating a new virtual host, you can create empty root directory and set up from beginning; or you can copy the DEFAULT virtual root that shipped with the package to this virtual host root and then modify it.
    ------>8-------
  4. gcaplan

    gcaplan New Member

    Thanks for responding. But I'm still confused...

    The config file was writeable (all other config settings saved fine) and all directories pre-exist and are writeable by Litespeed (directories owned by apache with wrx perms, LS running as apache). The paths are correct (copy & paste from the shell). So why is the console saying they are not writeable? Pasting the same path directly into the xml config file restarts without error and works.

    Not a big issue because there is a simple workaround, but I'd still like to know what the problem is.

    By the way the instructions in the green box on a new vhost form need edited - there are a couple of bad typos.
  5. webizen

    webizen New Member

    The lsws config file should be writable or owned by lsadm user which is different from LS web server user (apache in your case). So if the file is owned by web user but not writable by lsadm user then web console will complain.

    Thanks for pointing out. The typos in the instructions will be corrected.
  6. gcaplan

    gcaplan New Member

    Ah.. As the console is running in LS, I just assumed it ran as the same user. So where do I set the lsadmin user - I can't see a config setting for this? It does seem confusing to have 2 users - is this a security feature? I can't be the only one who's been caught out this way...
  7. webizen

    webizen New Member

    lsadm user gets created during the installation stage by the install script (install.sh). It is a security feature since admin console runs on a different port (7080 by default). During the install, you are prompted for setting up admin user & password for web console login.

    Please look at the details create_lsadm() in /path/to/lsws/source/functions.sh. create_lsadm() gets called by installation() which is called by the install.sh.
  8. gcaplan

    gcaplan New Member

    Thanks for the explanation!

    Can I suggest that if you are tidying up the instructions in the green box at the top of the Add VH screen, you could make this permissions issue clearer. It's not at all intuitive, and I for one got stuck...
  9. webizen

    webizen New Member

    Thanks for the suggestion. We'll take that into consideration for the future releases.

Share This Page