Won't Compile w/ Settings.

Discussion in 'Bug Reports' started by Matthew_K, Apr 27, 2008.

  1. Matthew_K

    Matthew_K New Member

    I cannot for the life of me figure out why this is:

    I have two identical Litespeed web servers. Both have the same php settings and what not.

    With one, when I compile with certain settings, it works and takes the settings as shown by phpinfo.

    With the other, it will not accept any new settings.

    I'm compiling with: --with-ffmpeg=/usr/lib/php5/20060613/ --with-mysql --with-zlib --with-gd=/usr/lib --enable-shmop --enable-track-vars --enable-sockets --enable-sysvsem --enable-sysvshm --disable-magic-quotes --enable-mbstring --with-iconv --with-jpeg-dir=/usr/lib --with-magickwand --with-curl --with-mcrypt --enable-ftp --with-freetype-dir= --with-ttf --enable-gd-native-ttf --enable-gd-jis-conv

    But the server that won't take new settings stops at --with-mcrypt. That's the last item it takes.

    On the other server the phpinfo shows all the settings correctly.

    With the one that doesn't work, the log shows that it compiled correctly with all the settings. But still, for some strange reason it acts like it doesn't install the newly compiled version.

    Any advice?
    Last edited: Apr 28, 2008
  2. Matthew_K

    Matthew_K New Member

    Also, I just noticed the build date the one that wont change says: Apr 8 2008 13:12:47

    The one that will change says: Apr 27 2008 04:27:26

    So the build is definitely not installing on the other system.
  3. mistwang

    mistwang LiteSpeed Staff

    Make sure you are using lsws/fcgi-bin/lsphp5 for the lsphp external app.
    PHP binary should be installed to lsws/fcgi-bin/lsphp-5.2.5, please check the timestamp.
  4. Matthew_K

    Matthew_K New Member

    This is interesting... I go to that directory in my FTP client, and it shows the date on it is 4/8/2008. But when I try to open it I get this message: "Directory /opt/lsws/fcgi-bin/lsphp-5.2.5: no such file or directory"
    I assume that IS the binary and that my FTP client thinks it's a directory. Either way, the date on that is 4/8.

    EDIT:
    On the other web server it says that it is 4/27/2008.
    Last edited: Apr 28, 2008
  5. mistwang

    mistwang LiteSpeed Staff

    try removing it and build again.
  6. Matthew_K

    Matthew_K New Member

    I just renamed the old ones as backups, recompiled and the new ones are there with the right date. I don't know if the changes were made yet, since my load balancer is throwing everything to the other server right now, but I will check soon and report back. But so far so good.
  7. mistwang

    mistwang LiteSpeed Staff

    It is better to have a dedicate domain name for each backend node for trouble shooting purpose.
  8. Matthew_K

    Matthew_K New Member

    OK. I'll do that. That's a good idea.
  9. Matthew_K

    Matthew_K New Member

    OK, happy to say it worked! Thanks, Mistwang. As always, you've been a big help!
  10. Matthew_K

    Matthew_K New Member

    Upgraded to .13 and tried to recompile just now. Same problem happened. I went into the /opt/lsws/fcgi-bin folder and renamed the old files, recompiled and the new one did not show up at all.

    Any suggestions?
  11. mistwang

    mistwang LiteSpeed Staff

    Does /opt/lsws/phpbuild/php-5.2.6/sapi/littespeed/php get created?
    Any error in the build log?
  12. Matthew_K

    Matthew_K New Member

    Nope. Here's the contents of that folder:

    Code:
    server02:/opt/lsws/phpbuild/php-5.2.6/sapi/litespeed# ls
    config.m4   lsapilib.c  lsapi_main.c   README
    lsapidef.h  lsapilib.h  Makefile.frag
    That's the same on both of my web servers.
  13. mistwang

    mistwang LiteSpeed Staff

    The build failed, you can check the build log under lsws/phpbuild directory.
  14. Matthew_K

    Matthew_K New Member

    There are a LOT of log files in there. I'm going to look through and see if I can find anything. Thought it may be just easier to try again and use that log file.
  15. Matthew_K

    Matthew_K New Member

    Found this towards the end of the log:

    Build complete.
    Don't forget to run 'make test'.

    mv /opt/lsws/fcgi-bin/lsphp-5.2.6 /opt/lsws/fcgi-bin/lsphp-5.2.6.bak; cp /opt/lsws/phpbuild/php-5.2.6/sapi/litespeed/php /opt/lsws/fcgi-bin/lsphp-5.2.6
    mv: cannot stat `/opt/lsws/fcgi-bin/lsphp-5.2.6': No such file or directory
  16. mistwang

    mistwang LiteSpeed Staff

    Looks like it does not build PHP with LiteSpeed SAPI at all.
    I think you should check your configuration parameters, and make sure to remove those related to other SAPI modules, like Apache (--with-axps), or fcgi (--enable-fastcgi), etc.

    A set of files will be created each time you build PHP through the web console, you can remove those files.

Share This Page