Joomla 5 compatibility

JSW3

New Member
#1
hey folks, is the latest joomla plugin compatible with joomla 5? when running the update check it tells me that the latest one (10-18-2023 ) may cause issues, has any testing been done?
 

serpent_driver

Well-Known Member
#5
I tried it, and it does not work without compatibility plugin
Could you please specify what is going wrong?

**********************************************************************************************************************************************************************************
Join https://www.cachecrawler.com - Lightning fast Cache Warmup Crawler for Wordpress, OpenCart, PrestaShop, W3 Total Cache, WP Rocket, Shopware and Magento.

support-partner-label.png
 
#6
Hi there,
As you might be aware, in Joomla 5 you can/should disable the Backward Compatibility plugin. More information about this on
https://magazine.joomla.org/all-iss...ility-plugin-and-why-you-should-switch-it-off

Any extension which works on J5 without requiring the Backward Compatibility plugin is actually J6-ready.

I have just downloaded the latest J5 package from
https://github.com/litespeedtech/lscache-joomla/tree/master/Joomla5/package
but there are still 2 errors which crash the site when disabling the Backward Compatibility plugin:

1.
Attempted to load class "JModuleHelper" from the global namespace.
Did you forget a "use" statement?
in /home/smeddzxm/public_html/administrator/modules/mod_lscache_purge/mod_lscache_purge.php (line 5)
Code:
require JModuleHelper::getLayoutPath('mod_lscache_purge', $params->get('layout', 'default'));
2.
Class "JComponentHelper" not found
JROOT/plugins/system/lscache/lscache.php:60

As soon as this is fixed I will be happy to test the new version :)
And so does @serge_web54 ao ;)
Txs!
 
Top