[solved] Gzip

Discussion in 'General' started by pardis, Aug 11, 2014.

  1. webmastergreg

    webmastergreg Member


    sorry double checked all where I could have some SetEnvIf and BrowserMatch, cleaned all my .htaccess in every virtual domains and set too off all the sites optimisations from cPanel (the one who put the htaccess with BrowserMatch at the root of the domains)

    Issue still the same:
    Version <= 4.2.12 = OK

    I will check again....just in case of my eyes..
  2. mistwang

    mistwang LiteSpeed Staff

    I think we have to login the server to investigate what causing it.
  3. mistwang

    mistwang LiteSpeed Staff

    Also, you need to make sure to get latest 4.2.14 build with

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.14
  4. mistwang

    mistwang LiteSpeed Staff

    One related bug has been fixed with latest 4.2.14 build. Please force reinstall 4.2.14 see if the issue has been addressed or not.
  5. webmastergreg

    webmastergreg Member

    sorry for the late reply

    ok FIXED

    Thanks a lot !
  6. xUx

    xUx New Member

    This post saved my life, reinstalling 4.2.14 fixed gzip, thanks!

    Is there any way to use curl and get the "Content-Encoding: gzip" from a LiteSpeed page? I've tried a couple using -H "Accept-Encoding: gzip ,deflate" with no success, however the site is being gzipped. Could that be related to how php parses the output? If you call a txt/js/css file directly, you will see the content-encoding, but not directly from the php output. Any ideas?
  7. NiteWave

    NiteWave Administrator

    I tried, following curl works:
    #curl -o t1.html -i -H "Accept-Encoding: gzip ,deflate" http://blog.litespeedtech.com
    #curl -o t2.html -i --compress http://blog.litespeedtech.com
    above t1.html/t2.html has "Content-Encoding: gzip" response header

    #curl -o t3.html -i http://blog.litespeedtech.com
    t3.html has no "Content-Encoding: gzip" response header

    #curl -I -H "Accept-Encoding: gzip ,deflate" http://blog.litespeedtech.com
    has no "Content-Encoding: gzip" either.
    so get headers only(curl -I) won't trigger gzip

    not sure what's behavior under apache or nginx
  8. xUx

    xUx New Member

    Thanks! that helps a lot :) apache and nginx work with -I
    Michael likes this.

Share This Page