[solved] (Hopefully) Simple Question Related to Joomla Installations

Discussion in 'General' started by BoardBoss, Sep 3, 2013.

  1. BoardBoss

    BoardBoss Member

    **SOLVED** (Hopefully) Simple Question Related to Joomla Installations

    Hello all. I have been running Joomla installations for years without serious issues. Recently I moved a client site onto a server running LiteSpeed, and have encountered the following:

    Frontend: The site appears to be broken unless and until I add "index.php" at the end of the URI.

    Administrator: After using the correct credentials to log in, I receive a 404 error.

    Now comes my (hopefully) simple question: Can Joomla be run on LiteSpeed WITHOUT modification of anything related to Joomla?

    I have seen suggested core Joomla file hacks, suggestions for modifying the .htaccess file, and a few other suggestions.

    <opinion>That is all great, but, basically, screw that. If LiteSpeed is supposed to be a real Web server, and a replacement for Apache, then it should not be necessary to modify ANYTHING to make LiteSpeed function like Apache.</opinion>
    Last edited by a moderator: Sep 6, 2013
  2. NiteWave

    NiteWave Administrator

    simple answer: should not need any modification and just works fine.

    but we need investigate individual case to see where the problem is.

    the answer also simple: if the issue is easy to reproduce at our lab or on a customer's server, then the problem is nearly 90% resolved. recently few days, I've heard of a few issue reports regarding Joomla, but not heard of it before.

    please refer

    please force re-install 4.2.4, see if it still exists.
    if still there, can you help us to reproduce the issue at our lab or provide us the access to your server.
  3. BoardBoss

    BoardBoss Member

    I am encountering this with a new hosting provider that I just signed up with. I can name them if you would like, or send a PM with their name. Therefore I don't know how I would be able to force reinstall anything.

    Also, I can PM you a link to a site on this new provider's server where this issue is appearing. The site in question was moved from a server where the issues I mentioned were not occurring, although that server was running Apache.
  4. BoardBoss

    BoardBoss Member

    I have just mentioned to this hosting provider that they need to work with you folks to resolve this ASAP. Your site states:

    "LiteSpeed Web Server is the leading high-performance, high-scalability web server. It is completely Apache interchangeable so LiteSpeed Web Server can quickly replace a major bottleneck in your existing web delivery platform. With its comprehensive range of features and easy-to-use web administration console, LiteSpeed Web Server can help you conquer the challenges of deploying an effective web serving architecture."

    Notice the part about 'completely Apache interchangeable'? That is obviously not correct. The site was moved from a server NOT running LiteSpeed (it was running Apache), yet used the same temporary URL configuration the new hosting provider claims is causing the issue.

    I referred the hosting provider to this thread. It either needs to be resolved very quickly, or I am going to have to move to a provider that either understand how to configure LiteSpeed to avoid this issue (if that is possible), or just find a provider that does not use LiteSpeed. It is not worth the headaches it appears to be causing.

    Does anyone know of any hosting providers running LiteSpeed that do not have this issue?
  5. NiteWave

    NiteWave Administrator

    we also hope identify the issue and resolve it ASAP.
    your co-operation is appreciated.

    if you know more technical detail, please let us know, either post here or by PM.
    which Joomla version, any special requirement, is the package publicly downloadable ? etc
  6. BoardBoss

    BoardBoss Member

    That would be great. I will be PMing you details very soon.
  7. BoardBoss

    BoardBoss Member

    Well, let me hold off on PMing anything for just a bit. Perhaps they have been making changes at the hosting provider, because now the issue has disappeared.

    At their request, we had manually changed the value for $sef from 1 to 0 in the configuration.php file to test. We had to do it manually by editing the file because we could not log into the Joomla admin area. For the record, $sef=1 is the default setting made by Joomla during installation.

    With it set to 0, it worked. Now, when we changed it back to 1, it still works. However, there are a couple of new issues that we noticed, so we don't know if those are related or new issues. In any case, we may not be able to continue working this way very long, as we need to move on with our development of the site, and this is starting to consume too much time.

    I like to help resolve issues when I can, that is just pretty much in my nature. That said, time is money, and time I spend resolving this is time I am not making money, and there are plenty of other hosts out there that are not having this issue. I am not sure if any use LiteSpeed; that is not my primary concern. My primary concern is that I am doing way too much thinking about something I should not have to expend one brain cell considering.

    I appreciate your expected understanding. Again, I will try to help you if I can, although that is not my primary concern.
  8. BoardBoss

    BoardBoss Member

    Just received from this hosting provider: "I'm afraid it's highly unlikely Litespeed will fix this due to the way it functions..."

    Okay, so then that begs the question: Just how compatible with Apache is LiteSpeed. Obviously it is NOT a direct replacement for Apache, or this issue would not be happening.
  9. mistwang

    mistwang LiteSpeed Staff

    This issue should have been addressed in latest 4.2.4 update, just ask your host provider to do a force reinstall of 4.2.4 .
  10. BoardBoss

    BoardBoss Member

    They finally updated to LiteSpeed version 4.2.4 today. They claim they did not mention the update to me previously because the change log did not list the issue I reported. Maybe not word for word, although I did see an issue related to .htaccess files.
  11. NiteWave

    NiteWave Administrator

    this issue resolved. not incompatible issue or bug.

    please read message from our developer to your host: "The problem is that mysql speed has been throttled by CloudLinux to a very slow speed. the install script takes very long time to finish DB creation operations. The connection timeout is set to 120 seconds and times out during installation. have increase it to 320, installation finished successfully. "

    I think the main lesson is: don't use CloudLinux to throttle mysql too much, otherwise maybe a nightmare for the whole server and all of the websites on it.
  12. BoardBoss

    BoardBoss Member

    Hi - I am not sure we are talking about the same issue. If something took 120 seconds to fail, I might think there was a connection with the MySQL throttling you mentioned. In this case, however, there was a bug in LiteSpeed that was apparently fixed in LiteSpeed version 4.2.4.

    The hosting provider had not upgraded LiteSpeed for almost a month after the release of 4.2.4, and after they did yesterday, this specific issue went away.

    I think the main lesson is: choose a hosting provider that is more proactive with installing updates that affect their clients.

Share This Page