[solved] unable to update

Discussion in 'Install/Configuration' started by bisqray, May 6, 2014.

  1. bisqray

    bisqray Member

    I'm currently running 4.2
    Trying to update to 4.2.10
    I tried using this command which seemed to work: /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.10
    2014-05-06 06:42:37.233 [NOTICE] Detected XEN VM
    2014-05-06 06:42:37.297 [NOTICE] [AutoUpdate] Checking for new releases..., pid=32572
    /usr/bin/wget -nv -O /usr/local/lsws/autoupdate/lsws-4.2.10-ent-x86_64-linux.tar.gz http://www.litespeedtech.com/packages/4.0/lsws-4.2.10-ent-x86_64-linux.tar.gz
    2014-05-06 06:42:43 URL:http://www.litespeedtech.com/packages/4.0/lsws-4.2.10-ent-x86_64-linux.tar.gz [3251199/3251199] -> "/usr/local/lsws/autoupdate/lsws-4.2.10-ent-x86_64-linux.tar.gz" [1]
    /usr/local/lsws/admin/misc/update.sh 4.2.10 ent x86_64-linux
    2014-05-06 06:42:44.099 [NOTICE] Memory size is: 1016636KB.
    2014-05-06 06:42:44.198 [NOTICE] [OK] Updated license key has been created at /usr/local/lsws/autoupdate/lsws-4.2.10/license.key.
    Restarting LSWS
    [OK] Send SIGUSR1 to 18146

    But I'm still running 4.2 (restarted again to be sure).

    Then I tried updating from the web console version management page but got "Error: Failed to download release 4.2.10! Please try upgrade manually"

    Any ideas how to proceed?
  2. mistwang

    mistwang LiteSpeed Staff

    Please check output

    ls -l /usr/local/lsws/bin

    if lshttpd is pointing to lshttpd.4.2.10 , it has been upgraded.

    /usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.10

    again to get latest build.

    Maybe you need to a full stop/start. do

    killall -9 litespeed
    /usr/local/lsws/bin/lswsctrl start
  3. bisqray

    bisqray Member

    Thanks that helped me realize that my upgrade license has expired.
    That's why it won't update. :rolleyes:

Share This Page