LiteSpeed Configuration for high traffic web

Discussion in 'Install/Configuration' started by LowKey, Jan 4, 2013.

  1. LowKey

    LowKey New Member

    Hi,

    After running LiteSpeed for 1 weeks, seems i the server run fast (when user around 100-500online) but still not happy enough with LS, even still having issue on LS Cache.

    I need some tips from LiteSpeed Staff for my configuration. My configuration is not tuned very well. Hope you guys can look at my current setting.

    This server is running social network application (phpFox). Currently have 28K member register and average user online 500-1000 online members.

    We have 2 server with running Dedicated Web server(LiteSpeed) and Dedicated MySQL Server(MariaDB).

    Webserver Spec : 8CPU/24GBRAM/250SSD/1000Mbps Port
    MySQL Spec : 8CPU/8GBRAM/1TBHDD/1000Mbps cross-connected VLAN to Webserver

    However, with my setting on LiteSpeed , we still having some issue with load page.

    Problem:
    1) The website getting slow when many concurrent users visited to the website (when reach 600-900 online members)
    2) Load average server become high. (load average: 67.23, 60.45, 53.13)
    3) LS Cache Hits : Low (still working on this issue)
    4) Request Timeout Problem when huge user visit the website

    Here my current setting on LiteSpeed

    Quick Configuration of PHP suEXEC (Currently disabled)
    Quick Configuration of LiteSpeed Private Cache (Currently enabled)

    http://cl.ly/image/1q3L1B1L0f0r
    http://cl.ly/image/2F0U2E2g1q1I
    http://cl.ly/image/0S3p0Z3t0I1O
    http://cl.ly/image/1d2R2C1B1c07
    http://cl.ly/image/1p1n0G1k0S0W
    http://cl.ly/image/2w0J0A2q2A3W
    http://cl.ly/image/0A0n1w2B073A


    Hope you can check my setting.


    Thanks.
    Last edited: Jan 4, 2013
  2. NiteWave

    NiteWave Administrator

    lsphp5 settings:
    http://cl.ly/image/1d2R2C1B1c07
    Max Connections:1000 --> too large ? suggest 100 or 200
    PHP_LSAPI_CHILDREN=500: should match "Max Connections", i.e., 1000. suggest 100 or 200
    Instance:10 -> change to default 1

    Run On Start Up:Yes --> change to suEXEC Daemon

    http://cl.ly/image/1q3L1B1L0f0r
    Priority:-4 --> suggest to try 0

    http://cl.ly/image/2F0U2E2g1q1I
    Smart Keep-Alive:Yes -- > No

    http://cl.ly/image/0A0n1w2B073A
    ajax.php is busiest one. see if possible to cache it

    as discussed before, if able to enable lsws page cache correctly, the load may drop significantly; however this may need good knowledge of PHPFox.
  3. LowKey

    LowKey New Member

    I'm already changed all the setting as mention.

    How to cache ajax.php ? Is that correct?

    The path is /www/static/ajax.php

    Please let me know.

    Thanks
  4. marsh12

    marsh12 New Member

    i like this topic its good.......

Share This Page