LS Cache + WordPress

Discussion in 'LiteSpeed Cache' started by 04nunhucks, Jun 1, 2011.

  1. 04nunhucks

    04nunhucks New Member

    Hello,

    I'm using imported vhosts via cPanel/LS, and trying to setup LS Cache. Problem is, when adding one particular line to my htaccess file, the thing fails: RewriteRule (.*\.php)?$
  2. NiteWave

    NiteWave Administrator

    can you post here the whole .htaccess if it's not too long
  3. 04nunhucks

    04nunhucks New Member

  4. NiteWave

    NiteWave Administrator

    rewrite rules from w3total cache take priority in your .htaccess, so the rewrite rule you added won't reach at all.

    both w3total cache and lsws cache are page cache to cache wordpress pages, you only need one at a time, not both.
  5. 04nunhucks

    04nunhucks New Member

    Which one would you suggest I keep? Which one is better/faster?
  6. NiteWave

    NiteWave Administrator

    I suggest you to keep w3total since it's out of box solution.

    lsws page cache is a general cache function, to have it work perfectly with wordpress, need some extra work to customize the rewrite rules.
  7. 04nunhucks

    04nunhucks New Member

    Thanks NiteWave.

    I seem to having a small issue with LS though.. some pages seem to take quite a while to load, it seems sporadic.
  8. webizen

    webizen New Member

    Can you be more specific? is it like a page takes long time at one point and ok at a different time? It could be cache expired, etc.

  9. 04nunhucks

    04nunhucks New Member

    Overall, my website just feels a bit sluggish.

    Well, I've disabled W3 Total Cache.

    What I do, is visit a few pages, using the navigation bar, but once I'm on the Contact Me page, when I try to go back to the home page, the browser sends the request, then it hangs for a bit, then loads the page.

    Any ideas?

    This happens with or without W3 Total Cache, so it's not that.

    website, http://shamil.la
  10. webizen

    webizen New Member

    The contact me page shows error as below. However, go back to the home page (http://shamil.la) from that page isn't slow to me. maybe it is user specific issue such as user network, etc.

  11. 04nunhucks

    04nunhucks New Member

    LS Cache was caching that. Please check now :)
  12. webizen

    webizen New Member

    The home page doesn't seem to be served from LS cache but W3 Total Cache..

    Anything served out of LS cache has "X-LiteSpeed-Cache: hit" in its response header. This one does not have such response header.
  13. 04nunhucks

    04nunhucks New Member

    W3 Total cache has been disabled a loong time ago, just before I posted about it being slow. All plugins have been disabled since then.

    LS Cache was only recently turned off, and the error went. FWIW, I wasn't getting the error in Safari (MAC), but Firefox, (MAC) was, and it could see a cached version of the page.
  14. webizen

    webizen New Member

    turn off FF browser cache to see any difference.

    Following is the response header received in Firefox (Mac). Still served from W3 Total Cache.
  15. 04nunhucks

    04nunhucks New Member

    It is now deactivated.

Share This Page