Lsws 4.2.5, php lsapi 6.4

Discussion in 'Install/Configuration' started by theRKF, Nov 8, 2013.

  1. theRKF

    theRKF Member

    I'm sorry to surface this issue again, but I'm still not getting a good grasp on the best implementation for our situation and I'm hoping to clarify.

    Understanding that:
    • We have a dedicated server running CentOS
    • Using WHM/cPanel
    • Multiple versions of PHP
    • We have to compile PHP via command line

    PHP 5.4.21 (latest in the 5.4.x branch) is still shipping with LSAPI 5.5.

    Clearly there have to be benefits from upgrading LSAPI to 6.4.

    I've tried downloading 6.4 and unzipping into the PHP source folder as instructed, but that always generates errors during configure/make.

    What else do I need to do when compiling PHP to make use of the latest LSAPI version?
  2. wanah

    wanah Member

    Last time I tried that (with LSAPI 6.3) I didn't get any erros, nor did I do anything special other than replace the LSAPI 5.5 files and compile with the --with-litespeed option.

    What errors are you getting ?
  3. mistwang

    mistwang LiteSpeed Staff

    You can use the "build PHP" feature from LSWS web console. it will apply latest LSAPI.
    When you apply LSAPI 6.4, you only need to copy over *.c and *.h, do not change Makefile.frag and config.m4 .
  4. webmastergreg

    webmastergreg New Member

  5. wanah

    wanah Member

    This means that you have a matching php version but not necessaraly the latest lsapi.

    We had the same so we just ran "Build matching php version" and it recompiled php with the new lsapi without going through all the easyapache process.
  6. webmastergreg

    webmastergreg New Member

    Thanks, will test that ASAP :)
  7. theRKF

    theRKF Member

    I just tried again with LSAPI 6.6

    Code:
    make: *** No rule to make target `litespeed', needed by `all'.  Stop.
    root@server [/usr/src/php-5.4.22]#
    FYI: Because of the nature of our server setup I have to compile via command line.

    Here's my configure command:
    Code:
    './configure' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-gd-native-ttf' '--enable-intl' '--enable-libxml'  '--enable-mbstring' '--enable-pdo=shared' '--enable-soap' '--enable-sockets' '--enable-zip' '--prefix=/usr/local' '--with-curl=/opt/curlssl/' '--with-freetype-dir=/usr' '--with-gd' '--with-icu-dir=/usr' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libexpat-dir=/usr' '--with-libxml-dir=/opt/xml2' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-pic' '--with-png-dir=/usr' '--with-xmlrpc' '--with-xpm-dir=/usr' '--with-xsl=/opt/xslt/' '--with-zlib' '--with-zlib-dir=/usr' '--with-litespeed' '--with-mysqli=/usr/bin/mysql_config'
  8. mistwang

    mistwang LiteSpeed Staff

    when you manually apply LSAPI 6.6 code to sapi/litespeed, only copy over *.c *.h, do not change other files.
    Or, use LSWS web console to prepare the code for you.

Share This Page