3.3.11 eAccelerator install error 404 off litespeedtech.com

Discussion in 'Install/Configuration' started by brrr, Apr 26, 2008.

  1. brrr

    brrr Well-Known Member

    3.3.11 + eAccelerator install errors

    I am attempting a completely clean install of LSWS Std, using the latest 3.3.11.

    The install.sh script runs fine until it comes to installing a cache.

    If you select [2] to install eAccelerator, the script fails at that point and generates a 404 off the Litespeedtech.com website because the install is looking for:


    and that file does not exist on the litespeedtech.com web site, for some reason.

    If you manually replace that file location with the 4.4.7 eac version in the relevant install script, install works fine.

    Edit: actually, even after editing the admin/misc/enable_phpa.sh install script to correct the eaccelerator file name that is pulled down off litspeedtech.com, the install still went awry - PHP couldn't find eaccelerator and 503 errors also started proliferating and LSWS crashed every time even the simplest php file was run, and then simply refused to start, throwing errors about umb:/ and sockets.

    So I've deleted my complete LSWS install and switched back over to Apache.

    If I run LSWS again, I think I'll go an re-install a LSWS edition from several versions back. Installing those was always effortless and they just worked. Installing 3.3.11 and trying to get php 4.4.8 configured with a cache on top of 3.3.11 has been a nightmare.
    Last edited: Apr 26, 2008
  2. mistwang

    mistwang LiteSpeed Staff

    You should use the admin console to build your own PHP and opcode cache binary now.
  3. brrr

    brrr Well-Known Member

    Hmmm. So are you saying that LSWS Std no longer offers to install a pre-built PHP or the option to install a PHP cache? If yes, that would certainly be a step backwards.

    At the moment those options still are in install.sh and IMHO should stay in the install procedure for LSWS as it makes setting up a LSWS quick and easy (when the script works).

    Anyway, I just downloaded the 3.3.11 installer and ran it again.

    The LSWS Std installer still barfs because it can't find the right eaccelerator .gz off your own web site. (See below).

    At a minimum you should either fix the install script or upload the correct file onto your server that the script is looking for so that install runs smoothly:


Share This Page