4.0 vs 4.1

Discussion in 'Bug Reports' started by IrPr, Nov 17, 2011.

  1. IrPr

    IrPr Well-Known Member


    Currently I've 2 major issues with 4.1 which forced me to stay with 4.0

    1st is well known bug litespeed process 100% CPU usage which is ocurring very randomly on busy servers and unfortunately all 4.1 series are affected by this issue, however aimed to be addressed in recent 3 builds but no any working properly fix yet
    As mentioned earlier the only interesting thing in 4.1 is AIO support and unfortunately I'm facing IOWAIT on one of servers which forced to install 4.1
    Its working well without any latency and wait but during 24 hours 2 or 3 times this 100% CPU issue is occurring which leads to many hours downtime and latency till I restart lsws
    Indeed this server is not stable with litespeed, both 4.0 and 4.1

    2nd one is more stranger
    however its very similar to 1st one but I don't find litespeed process in top and 100% CPU usage stage

    Recently we've got new high-end servers with 48 core (4x AMD Opteron 6176) and 80 core CPU (4x Intel Xeon E7 4850) and more than 100Ghz and 160Ghz CPU power but litespeed 4.1 wonderfully kills them very easily at the 1st peak time!
    Indeed CPU idle goes down to zero with litespeed/lsphp5 processes only, however I just switched back to 4.0.20 and the issue has been solved at the peak time
    In fact on all of high-end servers 4.1 eats my CPU resources badly, tested on many servers and I'm properly sure that there is major issues with 4.1 which is not suitable for high-end servers with high CPU powers, at least for me
    while 4.1 eats my CPU 4.0 could easily handle all requests with rational CPU usage

    To me 4.0 seems very more stable in compare of 4.1 but on servers with IOWAIT there is no stability and solution with LSWS

    Since its getting too long for this issue to being known but not resolved I would like to strongly ask LSWS developers to provide a reliable patch or any temporary solution for this

  2. mistwang

    mistwang LiteSpeed Staff

    One bug that causes 100% cpu has been fixed in 4.1.8 thanks for a quality bug report.
    You can give it a try on the server that you have to use 4.1 release.

    And believe me that we want those bug fixed more than anyone else.

    The main reason that those bugs has not been fixed is because that we could not reproduce those bugs in our lab and bug reports we received is vague and lack of useful information.

    The best and quickest way to have this type of bug addressed is to let us log in to your server and collect debug information, and quickly trying some fixes. There are many difficult bugs fixed in this way.

    But not everyone willing to do that as the production server is very important. we fully understood, and we are very careful and rarely cause extra more downtime than trying a new release themselves.

    In those cases, we try our best to give instructions to let user to collect useful debug data for us. but most time, people do not follow or gave up quickly.
  3. IrPr

    IrPr Well-Known Member

    Thanks for your quick response and understanding our situation

    I see that you are working hard on this and hope that we can solve it together ASAP

    Isn't 4.1.8 package released/uploaded yet? i got 404 not found

    Regarding permission that you asked I will talk my colleagues and probably will send you in private
  4. webizen

    webizen Well-Known Member

    not yet. but debug build is there.
  5. mistwang

    mistwang LiteSpeed Staff

    First 4.1.8 release build is uploaded. however, it is not the final build yet.
  6. IrPr

    IrPr Well-Known Member

    Still the same,

    tried on one of my busy high-end servers and starting 4.1.8 leads to this issue occurrence
    litespeed processes on the top and CPU eating

    I will send you login credentials to take a look into this yourself
  7. mistwang

    mistwang LiteSpeed Staff

    another 100% cpu bug in 4.1.8 has been addressed.
    It was actually introduced in 4.1.8, related to a change in handling Apache configuration.
    4.1.8 is running smoothly now.
  8. IrPr

    IrPr Well-Known Member

  9. mistwang

    mistwang LiteSpeed Staff

  10. IrPr

    IrPr Well-Known Member

    OK thanks
    installed on many servers, will update tomorrow after peak time

  11. anewday

    anewday Moderator

    Might want to update the build date to 11/18 for 4.1.8 on the download page. :)
  12. IrPr

    IrPr Well-Known Member

    Well, most of servers are still stable but I just reproduced this issue on peak time,

    One of mega servers was running 4.0.20 at the highest peak time, switched to latest 4.1.8 and boom ! CPU idle goes down to zero while it was about 50% before 4.1.8
    switched back to 4.0.20 and load went down

    I just see litespeed process after 4.1.8 at the peak time at the top,
    It seems that its stable when we switch to 4.1.8 at off-peak time and it will be okay when it got traffic peak, but during traffic peak switching to 4.1.8 kills the server easily while 4.0.20 is okay

    I guess starting 4.1.8 with high traffic and request leads to this issue

    George, seems that its not addressed yet, at least in this case
    Please let me know how to provide debug information to you? is it necessary to install dbg version and enable DEBUG to have core dumps enabled? or just change log level to DEBUG?

    Hope that we can find the right solution finally
    Last edited: Nov 19, 2011
  13. IrPr

    IrPr Well-Known Member

    Tried lsws-4.1.8-ent-x86_64-linux-dbg.tar.gz but no core dumps yet

Share This Page