Discussion in 'Bug Reports' started by mistwang, Nov 6, 2009.

  1. damianxd

    damianxd New Member

    Random seek problem

    I have a problem with the random seek feature. It doesn't seem to work on any player even if I check and recheck the mime types:
    f4v,mp4 = video/mp4

    When I try to load a video, it plays, but when I use the seek feature on flowplayer I've got an error and on jwplayer... well, it simply continue from some point near the begining of the video.

    Please check it out here:

    I don't know if I'm missing something, but please give me a hand with this
  2. NiteWave

    NiteWave Administrator

    please copy flowplayer-3.2.3.swf etc to your server and test again.

    need copy this file as well:
  3. damianxd

    damianxd New Member

    Sorry, that didn't help... I've placed all the flowplayer files on my server and still the random seek feature doesn't work.

    I've set another player with the same swf but with a different file source and you can see that the random seek from that server is working but not on mine.


    Kind regards
  4. mistwang

    mistwang LiteSpeed Staff

    random seek for mp4 video should work with the latest 4.1RC3 build now.
    Just change the version number in the download link to get it.
  5. meto

    meto Well-Known Member

    I confirm.
  6. ideaoforder

    ideaoforder Active Member

    Moov Atom

    Depending on how your video was encoded, you may also have to check that the moov_atom was moved to the beginning of the file. I think Quicktime puts it at the end by default. I think ffmpeg for mac/linux both come with a utility for doing this.
  7. meto

    meto Well-Known Member

    That's common to every Pseudo-streaming.
  8. aww

    aww Well-Known Member

    Just tried 4.1rc5 and it broke some some of my deeper directory rewrite rules for php. Root directories and static content did not seem to be affected.

    Since it was a live server I didn't have time to debug and rolled back to 4.0.20 which fixed the problem.

    (tried deleting the /tmp/lsws cache on 4.1 but it didn't fix it)
  9. NiteWave

    NiteWave Administrator

    Please back to latest 4.1RC4 if you were using 4.1 series.

    4.1RC5 has big change to support mod_security 2.5, while RC4 not.
  10. aww

    aww Well-Known Member

    Ah okay, will try. I actually upgraded from 4.0.19

    Also remembered the deeper directory was using RewriteOptions Inherit, which I didn't actually need, not sure if that was the trigger for the problem or not.

    Oh basically the way it was working was the virtual directories were not being rewritten at all, and a 404 was thrown, not sure if that helps you or not.
  11. webizen

    webizen Well-Known Member

    Yes, upgrade to 4.0.20 is the right path if you were running 4.0.* version.
  12. mistwang

    mistwang LiteSpeed Staff

    If you do not mind, please contact bug@litespeed... with detail of the rewrite rules involved, we will setup a test environment in our lab to reproduce this problem.

Share This Page