503 Service Unavailable

Discussion in 'General' started by netinternet, Aug 26, 2009.

  1. netinternet

    netinternet Member

    I am really tired of 503 errors. I have setup a new apache server and transferring some of my websites to apache. I have tried all versions, including 4.1.0RC1 and compiled php several times (5.2.8, 5.2.9, 5.2.10) but no luck. What is the exact cause of this problem and how can I fix? I have two servers with this problem and I am in a very big trouble...
    Thanks in advance...

    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] ExtConn::onRead()
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] LsapiConn::doRead()
    2009-08-26 22:40:16.724 [INFO] [XX.218.116.131:52103-0#APVH_example.com:lsapi] connection to [/tmp/lshttpd/APVH_example.com_Suphp.sock.164] on request #0, confirmed, 0, associated process: 32747, running: 1, error: Connection reset by peer!
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] [ExtConn] close()
    2009-08-26 22:40:16.724 [DEBUG] [uds://tmp/lshttpd/APVH_example.com_Suphp.sock] No Request has been processed successfully through this connection, the maximum connections allowed will be reduced!
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] HttpExtConnector::tryRecover()...
    2009-08-26 22:40:16.724 [NOTICE] [XX.218.116.131:52103-0#APVH_example.com:lsapi] Max retries has been reached, 503!
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] HttpIOLink::continueWrite()...
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] write resumed!
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] HttpIOLink::suspendWrite()...
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] HttpConnection::sendHttpError(),code=503 Service Unavailable^M
    2009-08-26 22:40:16.724 [NOTICE] [XX.218.116.131:52103-0#APVH_example.com:lsapi] oops! 503 Service Unavailable^M
    2009-08-26 22:40:16.724 [NOTICE] [XX.218.116.131:52103-0#APVH_example.com:lsapi] Content len: 0, Request line:
    GET /sorting/modify/item-showhtmllist-1/dir/a/attr/c,232,Teknik-Servis.htm HTTP/1.1
    2009-08-26 22:40:16.724 [NOTICE] [XX.218.116.131:52103-0#APVH_example.com:lsapi] Redirect: #1, URL: /index.php
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] redirect to:
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] processContext() return 15
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] HttpConnection::flush()!
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] Written to client: 662
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] HttpConnection::nextRequest()!
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] Non-KeepAlive, CLOSING!
    2009-08-26 22:40:16.724 [DEBUG] [XX.218.116.131:52103-0#APVH_example.com:lsapi] Shutting down out-bound socket ...
  2. mistwang

    mistwang LiteSpeed Staff

    Is it random or consistent with certain request.
    If it is consistent, it must be a problem with your PHP.
    Also, you should disable opcode cache during the trouble shooting.
  3. mistwang

    mistwang LiteSpeed Staff

    Feedbacks on 4.0.10 has been very reliable in term of 503 errors.
  4. netinternet

    netinternet Member

    I am sorry but my experiences are same about 503 errors. It is rondom, sometimes people get 503 error, somtimes blank pages. Is there a link to download older versions like 4.0.4? There was no problem with this version.

    BTW I really want to undersand the reason. For example what causes to "Max retries has been reached, 503!". May be there can is a configuration issue. I really need urgent help...
  5. auser

    auser Super Moderator

    just change the version number in the download URL. for example, latest one is
    change to

    can have a try and see if any difference.

    if GUI upgrade/downgrade fail, may need run command line as root:
    cd /path/to/lsws-4.0.4/

    update: sorry, looks like 4.0.4 not there where 4.0.6/4.0.9 still exists. if you ever downloaded 4.0.4, it may still exist somewhere on your server. for example /usr/local/lsws/...
    Last edited: Aug 27, 2009
  6. netinternet

    netinternet Member

    Yes I have tried that but iy gives 404. I think older versions are deleted from download repo. I have completely deleted whole lsws directory and made a fresh install but no luck. I have randomized 503 pages...
  7. mistwang

    mistwang LiteSpeed Staff

    You can get 4.0.6 which is stable.
    If you want to switch between 4.0.10 and other version, you need to run the installer and do a manual upgrade.

    That's because the admin console uses suEXEC in 4.0.10 release.
  8. Blair

    Blair Member

    Add me to the list. Many people complaining of blank pages, many 503 errors in the logs. v. 4.0.9 Will try 4.0.10 upgrade.
  9. anewday

    anewday Moderator

    Never had a 503 error with 4.0.10.
  10. netinternet

    netinternet Member

    I have downgrade to 4.0.6 a couple days ago.
    For now, there isn't any complaint about 503 error...

Share This Page