access.log suddenly stopped logging

Discussion in 'Install/Configuration' started by marstall, Jan 21, 2007.

  1. marstall

    marstall Member

    my access.log now logs only 404's - no 200's or any other status code. Here is the <logging> section of my http_config.xml file:


    not sure where else to look to resolved this - crawled all kinds of forums, checked permissions, tried different paths, filenames for the access log, etc.

    I am running LiteSpeed/2.2.6 Standard with Rails via LSAPI, multiple vhosts (24), on Red Hat ...

    any ideas? help is greatly appreciated ...
  2. mistwang

    mistwang LiteSpeed Staff

    Is there a dedicate access log file for each vhost?
    The server level access log will only log 404 requests does not belong to any vhost, unless vhosts are configured to log access to server log.
  3. marstall

    marstall Member

    thanks i will try that

    thanks i will try that - i forgot to add that this suddenly started happening a few months ago after working fine for several months (had vhosts before and after)
  4. marstall

    marstall Member

    thanks, that worked!!

    just had to go into the admin UI, click on my VHOST name, click "Edit" in the Access Log section, select "server's log file" from the log control drop down, and this created the needed section in my VHOST. on restart i got full logging for that vhost, now i will replicate 23 more times!

    thanks so much for the timely reply on a saturday night!

Share This Page