Admin login problems

Discussion in 'Bug Reports' started by felosi, Oct 30, 2009.

  1. felosi

    felosi Well-Known Member

    On the servers I have upraded to 4.0.11 I cannot login the web console. It crashes any browser I try it with - chrome, ie, firefox. The login page comes up, I press the login button and it just sits there, IN IE it gave a warning about some script running on the page causing problems.

    Is anyone else having this issue? It is that way with every server I have upgraded to 4.0.11 on.
  2. NiteWave

    NiteWave Administrator

    manually run

    may resolve the issue.
  3. felosi

    felosi Well-Known Member

    same thing. Im gonna try a downgrade and see if that helps
  4. PSS

    PSS Well-Known Member

    Was this resolved? I'm not going to upgrade if there is a risk loosing access to admin CP.
  5. mistwang

    mistwang LiteSpeed Staff

    We use RSA key to encrypt user name/password now if plain HTTP connection is used. Sometimes, the javascript RSA encryption code does not like the RSA key pair and the script crashes. We have noticed that, and usually create a new pair of key can fix that. Sometimes, it takes for a while for the java script to finish.

    There is another solution to setup self signed SSL certificate for the admin listener, if connection is encrypted, the javascript RSA encryption will be turned off.
  6. Clockwork

    Clockwork Well-Known Member

    same problem here, I'm also receiving this error in the error.log:

  7. mistwang

    mistwang LiteSpeed Staff

    Which user "admin_php" run as? lsadmin?
    who own /usr/local/lsws/admin/conf/jcryption_keypair? what is the permission mask for jcryption_keypair and /usr/local/lsws/admin/conf/.
  8. Clockwork

    Clockwork Well-Known Member

    yes, lsadm

    -rw------- 1 www-data www-data 530 13. Nov 11:22 jcryption_keypair

    drwx--S--- 2 lsadm lsadm 4096 13. Nov 11:22 conf
  9. mistwang

    mistwang LiteSpeed Staff

    jcryption_keypair should be owned by lsadm:lsadm
  10. Clockwork

    Clockwork Well-Known Member

    works, thanks.

Share This Page