admin login proboem after upgrade to 4.0.12

Discussion in 'General' started by tiga, Feb 17, 2010.

  1. tiga

    tiga Member

    After I upgraded the lsws server from 4.0.9 to 4.0.12, it shows the following error at the login page. Websites work but can't login admin. Any idea? Thanks

    Warning: session_start() [function.session-start]: open(/opt/lsws//admin/tmp/sess_5665af9d474038650d9f9a01cd898ff6, O_RDWR) failed: Permission denied (13) in /opt/lsws/admin/html.4.0.12/classes/ws/CLIENT.php on line 41

    Warning: Unknown(): open(/opt/lsws//admin/tmp/sess_5665af9d474038650d9f9a01cd898ff6, O_RDWR) failed: Permission denied (13) in Unknown on line 0

    Warning: Unknown(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/opt/lsws//admin/tmp) in Unknown on line 0
  2. NiteWave

    NiteWave Administrator


    chmod 710 /opt/lsws/admin/tmp

    if still not, simply
    chmod 777 /opt/lsws/admin/tmp
  3. tiga

    tiga Member

    chmod tmp to 777, the error gone but it just stays at the login page a minute after clicking the login button then shows "503 Service Unavailable "
    Last edited: Feb 17, 2010
  4. mistwang

    mistwang LiteSpeed Staff

    Please close the browser window and try again, the permission mask of /opt/lsws/admin/tmp should not be changed.



    if it still does not work.
  5. tiga

    tiga Member

    Still doesn't work. Here is what I found in the error log:

    2010-02-17 12:53:06.265 [NOTICE] [] [STDERR] /opt/lsws/conf/httpd_config.xml is not a valid file.
    2010-02-17 12:53:39.047 [INFO] [] ExtConn timed out while processing.
    2010-02-17 12:53:39.047 [INFO] [] connection to [/tmp/lshttpd/admin_php.sock.929] on request #0, confirmed, 0, associated process: 30276, running: 1, error: Connection timed out!
    2010-02-17 12:53:39.047 [NOTICE] [] Suspicious request timeout, associated process: 30276, running: 1.
    2010-02-17 12:53:44.880 [NOTICE] [] [STDERR] /opt/lsws/conf/httpd_config.xml is not a valid file.
  6. mistwang

    mistwang LiteSpeed Staff

    admin_php should run as user "lsadm", if not, you need to restart lsws from command line.
  7. tiga

    tiga Member

    admin_php is running as user apache. I tried to change the user to lsadm in httpd_config.xml but it fails to startup.
  8. tiga

    tiga Member

    Attached the config file here

    Attached Files:

  9. mistwang

    mistwang LiteSpeed Staff

    You need to check if user "lsadm" has been added to /etc/passwd or not.
    you can run the installer from lsws-4.0.12 package and do a manual update.
    Then restart LSWS.
  10. tiga

    tiga Member

    Yes, the user and group lsadm has been added

    I downloaded the package and update again a few times but it is the same.
  11. mistwang

    mistwang LiteSpeed Staff

    Is /opt/lsws/conf has permission like
    admin_php should run as the owner of conf/ directory.
  12. tiga

    tiga Member

    4.0.12 won't work. I have to switch back to 4.0.9 :(
  13. mistwang

    mistwang LiteSpeed Staff

    You can try a complete reinstall of 4.0.12, not sure what messed up the permission.
    Which control panel you uses? DA?
  14. tiga

    tiga Member

    It is a production server, so I don't want to mess it up again.

    Yes, it is running DA.


Share This Page