After Uninstall, websites really really slow

Discussion in 'General' started by azn_romeo_4u, Oct 6, 2008.

  1. azn_romeo_4u

    azn_romeo_4u Well-Known Member

    Right after my free license expired my websites were down for an hour. So I uninstalled litespeed, but now all my websites are going really really slow.

    Load is all under 1, but just the websites are slow. Before I installed litespeed everything was loading fine, wasn't even close to being bad as this, but now I can't seem to load 3kb gif files without it lagging. All my websites are timing out. I"m running apache 2.2
    Last edited: Oct 6, 2008
  2. mistwang

    mistwang LiteSpeed Staff

    Are you using control panel?
    If use cPanel try restoring /usr/local/apache/bin/httpd from httpd_ls_bak, if have not done yet.

    reinstall Apache is another option.
  3. azn_romeo_4u

    azn_romeo_4u Well-Known Member

    Thx, I reinstalled apache, since httpd_ls_bak doesn't appear to be in that directory.

    same problem, websites not loading or just going super slow.
  4. mistwang

    mistwang LiteSpeed Staff

    You have to try tuning Apache configuration then. Maybe MaxClients is too load or your site is under attack.
  5. azn_romeo_4u

    azn_romeo_4u Well-Known Member

    Thank you mistwang. In deedy it was a dos attack thank you. It happened after few hours before the license expired.

    I have one other question, how much faster is a 4 core cpu compared to the 2 core? Like what kinda boost would you see?

    Also, because my license expired (free version) if i opt into the monthly payments, can I still use the whm plugin to reinstall it?
  6. mistwang

    mistwang LiteSpeed Staff

  7. azn_romeo_4u

    azn_romeo_4u Well-Known Member

    Okay I got the the 2 cpu lease.

    Use the WHM plugin to install.
    Use the plugin to build matching php binary
    Everything started okay,

    But then I log into admin panel, I try to compile php with

    suhosin, mail header and xcache and i got this error.

    I wanted to see if xcache would help my server more.
  8. mistwang

    mistwang LiteSpeed Staff

    You need to make the permission on "gcc" "ld" relax a little bit, at least during building PHP from web console.
  9. azn_romeo_4u

    azn_romeo_4u Well-Known Member

    lol, total newbie at this stuff. What does make the permission on "gcc" "ld" mean?
  10. mistwang

    mistwang LiteSpeed Staff

    ls -l /usr/bin/gcc /usr/bin/ld
    chmod 0755 /usr/bin/gcc /usr/bin/ld
  11. azn_romeo_4u

    azn_romeo_4u Well-Known Member

    thank you, now I ran into another problem.

  12. PSS

    PSS Well-Known Member

    You'll need to install libpng devel package. Like

    yum install libpng-devel
  13. azn_romeo_4u

    azn_romeo_4u Well-Known Member

    Thank you, I tried it, and it still returned the same error.
  14. mistwang

    mistwang LiteSpeed Staff

    I think the best way to do it is build Apache with ezapache with similar configuration. Then build matching PHP with LSWS plugin. cPanel will install all libraries required for you.

    Then if you do not want to build xcache manually, you can build PHP from web console using the exact same configuration in the phpinfo() page.
  15. azn_romeo_4u

    azn_romeo_4u Well-Known Member

    Thank you I done that I get the same errors. I think i'll just forget about the opcode for now. However I got another question,

    I get e-mails from cpanel, saying httpd has crashed. But I never gotten those when I ran the trial version. I thought httpd was part of apache, but I have litespeed on. The trial version never had those crash messages when I ran it.

Share This Page