after upgrade, httpd_ls_bak error

Discussion in 'Bug Reports' started by aww, Jul 23, 2008.

  1. aww

    aww Well-Known Member

    I've always had this httpd_ls_bak error after upgrades, seems minor but figure I better report it:

  2. mistwang

    mistwang LiteSpeed Staff

    The error message is mainly because some version of Apache support "-k" option, some version does not. We are aware of it and will address it later.

  3. iCARus

    iCARus Member

    We got on one server similar problems. LSWS just stop working. Proces lshttpd hits CPU to 100% for couple of minutes. We tried to restart/stop/start lsws and is just ignoring.

    After couple of starts working again.

    This LSWS works before upgrade great without any downtimes. Now every day we suffer this strange bug/problem.

    Any idea ?

    we are now swiching back to v3.3.14 to see if this happen again.
    Last edited: Jul 27, 2008
  4. mistwang

    mistwang LiteSpeed Staff

    We have noticed the "failed to start listener on address *:7080" problem on one server, we will have it addressed in 3.3.16.

    But the 100% cpu of lshttpd is something else, if you notice that again, please strace it, then "kill -USR2 <pid_of_100%_CPU_lshttpd>" to turn on debug logging, let it run for a little while, then kill it. send us the error log and strace log.
  5. iCARus

    iCARus Member

    This problem exist in v3.3.14 too.

    But strange:

    After lshttpd is on 100% CPU, is like this
    If everything is ok then top shows(with slash and dot):

    This is really annoying while every day we go downtime of couple of min.
  6. mistwang

    mistwang LiteSpeed Staff

    The problem is mainly caused by high I/O wait due to more than 20,000 core files under /usr/local/apache/htdoc/mrtg/ directory. After removing those core files, the server run pretty smooth.

    If notice more problem just let me know.
  7. iCARus

    iCARus Member

    This problem still exist. We don't have anymore MRTG installed.

Share This Page