anyone had any problems with cpanel updates?

Discussion in 'General' started by felosi, Sep 14, 2007.

  1. felosi

    felosi Well-Known Member

    damn, I did, Been up 36 hours working on them. Their easyapache updated and its all to hell.
    Finally got ssl working again by doing apache 2, mod_userdir still messed up.
    Got cpanel support to look at the issue, here is their response. After I wrote a 2 paragraph ticket explaining that lsws does not change or alter any of their sh*tty apache stuff.

    lol, load average was .04 at the time he logged in. Does not good to explain to them that all lsws does is use the config and if modules are messed up in that config it wont work.

    A few months back, I had them go look at something, I forgot what it was but. They closed the ticket and said my server had been comprmised and rooted as I had a dangerous hacker tool process running called "psybnc"

    Im seriously about to give up these guys, I pay too much for that.

    Anyway, anyone know a way I can rig up mod_userdir?
  2. felosi

    felosi Well-Known Member

    Ahh I found the problem... I think
    The new cpanel apache setup compiles everything in and NOT as modules. Therefore, litespeed is unable to load the modules and use them?
    That sound right?
  3. felosi

    felosi Well-Known Member

    Yep, thats the issue.
    And there is no setting within easyapache to compile it the way its supposed to with modules.
    Might be a problem here unless they fix it. Because compiling apache1 does teh same way on new easyapache.
    Reason I had to do that easyapache, the webmail within cpanel went down, tried a few different things, only thing that would work. Im off to compile a custom apache now ;)

    Well mod_rewrite is built in too, no module. Will this cause a problem?

    UPDATE: Rewrite seems to still work
    Last edited: Sep 14, 2007
  4. mistwang

    mistwang LiteSpeed Staff

    LSWS does not load any Apache module, everything is built-in, LSWS only read the httpd.conf. For the userdir problem, you need to post related configurations in httpd.conf.
  5. felosi

    felosi Well-Known Member

    ah, thats a relief.
    Ok, Ill pm you a link to a copy of my httpd.conf if you dont care to look at it.

Share This Page