can't build PHP (4.4.8) on Cpanel 11 centos

Discussion in 'PHP' started by aww, Feb 22, 2008.

  1. aww

    aww Well-Known Member

    I don't seem to be able to build PHP 4.4.8 from the Litespeed menu on my fairly standard Cpanel 11 centos setup. (this is the first time I've ever tried this feature)

    I'm using Litespeed 3.3.5

    At first I wanted to try to add curl and openssl ( --with-openssl --with-curl) but I gave up on that for now and just trying standard settings, I get:

    Thanks for any advice - I've been going through some of the other threads with similar problems but can't find a working solution yet.
  2. aww

    aww Well-Known Member

    Well I must really be doing something wrong because even my manual attempt which worked fine for 4.4.7+lsaspi4.1+curl7.16.4 is failing now too.
    This is what I tried to do to get the newest versions (worked with the old)

    While everything seems standard up to the Make, this is what I get afterwards:
  3. aww

    aww Well-Known Member

    Ah, I bet this has to do with me upgrading to openssl 0.9.8g

  4. mistwang

    mistwang LiteSpeed Staff

    cPanel set the permission of "gcc" to only allow "root" user to run it. it is good for security, but break the build tool.

Share This Page