configure: error: cannot compute sizeof (char *)

Discussion in 'Install/Configuration' started by diggs, Jan 11, 2009.

  1. diggs

    diggs Member

    I do not believe this to be an issue w/ litespeed but I thought someone else here may have run into this issue.

    I'm having an issue when compiling php(5.2.6 or 5.2.8) with the litespeed api, that I've never seen before.

    OS = Cent 5.2
    php = 5.2.8
    mysql = 5.1.3
    lsws & lsapi are most current avail

    If I configure php without a ./buildconf --force to incorporate the litespeed api, it compiles fine.

    If I touch ac* , ./buildconf --force, and compile as I've always done in the past without issue, I'm getting an error on compile as follows.

    checking size of char *... configure: error: cannot compute sizeof (char *), 77 
    See `config.log' for more details.
    I seem to have narrowed this down to being an issue w/ the running of ./buildconf.
    I've tried autoconf213 as well as newest avail for distro autoconf259 w/ the same error in end.

    I did some digging first and found a few references to gcc and/or c++ being the culprit here. I've installed the most recent available through centos repositories.

    I also found some people that had this being a library path issue.

    I'm not confident that either is the case here seeing as it compiles just fine so long as I don't rebuild the config (which I have to, to build the lsapi).

    Here is the resulting config.log file > config.log

    Any input/tips on this would be awesome. I'm stumped.

    Thank you very much!
    Last edited: Jan 11, 2009
  2. mistwang

    mistwang LiteSpeed Staff

    the root cause of it should be

    in the config.log
  3. diggs

    diggs Member

    While I'm not quite sure exactly what this issue was, this allowed me to compile fully and get the server up and running w/ new php no problem.

    Granted this post was applicable towards apache, it has helped me here. I would love to know exactly what the issue was here if anyone knows.

    Referring post > HERE

    I was able to continue install and had no further issues w/ setup after this.

    Possibly the permission denied errors in my config.log were actually caused by this instead?

    Thank you.
    Last edited: Jan 11, 2009
  4. mistwang

    mistwang LiteSpeed Staff

    Yes, I think it is related to SELinux.

Share This Page