cPanel's webmail and cpanel ssl proxy give 404 errors

Discussion in 'Install/Configuration' started by wanah, May 26, 2014.

  1. wanah

    wanah Well-Known Member


    When I access https://webmail.domain.tld on a domain with an self generated SSL with SNI I get a 404 error.

    Do I have to configure something in litespeed for theses proxy's to work ?

  2. NiteWave

    NiteWave Administrator

    what version of lsws ?
    if below 4.2.11, you can try latest 4.2.11 or developing versuib 4.2.12, see if it's fixed or not.
  3. wanah

    wanah Well-Known Member

    I've got 4.2.11 and as this is a production server I would prefer to not have to install the developpement version.

    It seems to be working on sites that have their own IP but not on sites that share the main server IP.
  4. mistwang

    mistwang LiteSpeed Staff

    Can you please confirm it is working with Apache?
    It could be the SNI, as LiteSpeed does not do SNI with HTTPS proxy backend, we are adding it now.
    We may need temp root access and the real domain name to verify the root cause.
  5. wanah

    wanah Well-Known Member

    I think it is sni the issue as non sni accounts have it working, I'ill switch back to apache if it still doesn't work after you have added sni support to https proxy.

  6. wanah

    wanah Well-Known Member

    Ok, I tried to switch to Apache but Apache refused to start, so I'm going to wait for a very calm moment before trying the switch again…

Share This Page