eAccelerator only loads as zend extension (not as php extension)

Discussion in 'Install/Configuration' started by Michael.Terence, Jan 19, 2009.

  1. Michael.Terence

    Michael.Terence Active Member

    I just purchased a license and have compiled php5 via the web gui. I checked the box for Suhosin, and Mail Header patches, and selected the eaccelerator radio button.

    I loaded up did a graceful restart of lsws, and loaded up the phpinfo page - Suhosin and eaccelerator weren't loaded so I followed the php.ini path from the phpinfo page (in my case it was /usr/local/lsws/lsphp5/lib ) - created the php.ini file and added the following into it:

    Suhosin would load, but eaccelerator wouldn't. I verified that the path to the module was correct and finally added zend_extension=/path/to/eaccelerator.so instead of just extension=/same/path and it worked.

    I need the IonCube module and it won't work with eaccelerator loaded as a zend extension.

    What do I need to do to get eaccelerator to work as a regular php extension and not a zend extension?

    My php compile line is as follows:
  2. mistwang

    mistwang LiteSpeed Staff

    Try changing it to
  3. mistwang

    mistwang LiteSpeed Staff

  4. Michael.Terence

    Michael.Terence Active Member

    extension="eaccelerator.so" appears to have worked.

    why wouldn't this work when giving the full path?

    Thanks for the fix. :)
  5. mistwang

    mistwang LiteSpeed Staff

    PHP prepends "extensions_dir" for all PHP extension, does not for "zend_extension".

Share This Page