FreeBSD 6.2 - Invalid Credentials

Discussion in 'General' started by khatfield, Dec 14, 2007.

  1. khatfield

    khatfield Member

    Same issue as here:

    I have re-installed 3 times with different user id's. Checked permissions and everything I know to check. It installs and I can get to the interface fine but it keeps saying "Invalid Credentials".

    I have tried Firefox and IE7 - neither work. Tried clearing cookies etc... No luck. I have 3 servers we would like to purchase for but I am afraid we will have to find an alternative if this issue can't be fixed. Any suggestions?

  2. mistwang

    mistwang LiteSpeed Staff

    We will setup a test environment to have this issue fixed.
  3. mistwang

    mistwang LiteSpeed Staff

    OK, please try a simple patch to the web console code
    Open file lsws/admin/html/classes/ws/CLIENT.php, search for
    $salt = substr($pass,0,2);
    change it to
    $salt = substr($pass,0,CRYPT_SALT_LENGTH);
    Please let me know it works or not.
  4. khatfield

    khatfield Member

    This fixed the issue. Confirmed.

    Thanks for the fast response!

Share This Page