How to fix letencrypt's "domain.com inaccessible, please verify" issue?

#1
I have pointed the domain to digital ocean wp openlitespeed droplet but I get this error when I try to install letsencrypt

"Do you wish to issue a Let's encrypt certificate for this domain? [y/N]y
domain.com inaccessible, please verify." (domain = my domain changed it here)
I even bypassed cloudflare's privacy. My server IP is visible via DNS everywhere. I have set IP via A records.

Can one say how to fix this issue?
 
Last edited by a moderator:

Unique_Eric

Administrator
Staff member
#3
LiteSpeed's Images have all been updated and published on DigitalOcean's Marketplace.
The updates include the latest version and a patch for the Intel CPU MDS vulnerability issue.
If you previously encountered a WordPress 404 issue, please launch and try again. Thank you.
 
#4
Hello,
I am having the same issue. I can actually access the site by both IP and domain name, but the prompt to set domain pops up every time I ssh in to a new session. It fails identically to OP, however. I just created the droplet yesterday, so I believe I am using the most recent version. Any advice @Unique_Eric ?
 

Unique_Eric

Administrator
Staff member
#6
No problem, if your domain not support www, then you should just use mydomain.com only.
Feel free to open new post with new issues.
 
#7
Same problem. I try to enter my site using any syntax (http, https, www, without www ...), but I always get an error:

"Connection is not secure
Attackers may try to steal your data from shigaev.com (for example, passwords, messages or bank card numbers).
NET :: ERR_CERT_AUTHORITY_INVALID "

However, I can log in using IP. In this case, everything works.

Could you help me in solving this problem?

P.S. hmmm... A little later I tried to refuse SSL during installation. But the problem has remained the same.
 
Last edited:

Unique_Eric

Administrator
Staff member
#8
Hi @Shigaev ,

Please clarify if you have
1. Pointing your domain to the server?
2. Using the auto setup script to add the domain?
3. Did you apply for the Let's encrypt during the script?

By default image will auto add the server IP to the listener only, that's why you can access with IP.

Best
 
#9
1. I entered my domain name with "www".
2. To add a domain, I used a DigitalOcean droplet "OpenLiteSpeed WordPress" and its script proposed to me in SSH.
3. I agreed with the proposal to enable Let's Encrypt while the script is running. But was refused.

A few minutes ago I checked the site’s work from a mobile phone - the site was available. As expected - without a secure protocol.

Can you help me by suggesting what I should do to activate Let's Encrypt and get rid of the "NET :: ERR_CERT_AUTHORITY_INVALID" problem in my browsers on my home computer?
 
#13
Litespeed sounds like an oxymoron since I cannot get past the Let's Encrypt error

"Do you wish to issue a Let's encrypt certificate for this domain? [y/N]y
domain.com inaccessible, please verify." (domain = my domain changed it here)
 

Unique_Eric

Administrator
Staff member
#14
It maybe take a while to update the DNS after pointing the domain to the new server/IP.
@strunk let us know if you need any help to verify why domain failed to access.
 
Top