htaccess and DocumentRoot

Discussion in 'Feedback/Feature Requests' started by priestjim, Apr 14, 2009.

  1. priestjim

    priestjim Well-Known Member


    I am an LS Enterprise edition owner and I have noticed that while Apache tries to open and process .htaccess files located in every subdirectory containing the docroot (for example if docroot is /home/example/www, apache will process /.htaccess, /home/.htaccess and /home/example/.htaccess), LS doesn't! This is very crucial to CPanel because, for example, it uses it (through /home/example/.htaccess in order not to interfere with the actual website's .htaccess in /home/example/www/.htaccess) to enable users to choose between PHP versions!

    Is it possible to add this feature to LS?

    Thanks in advance!
    Last edited: Apr 14, 2009
  2. mistwang

    mistwang LiteSpeed Staff

    We will add that to 4.1 release.
  3. priestjim

    priestjim Well-Known Member

    Could you give me a rough ETA for version 4.1? I'm really burning my heels here...

    Thanks anyway :)
  4. mistwang

    mistwang LiteSpeed Staff

    We have produced a 4.0.3 release package including this. You can give a try.
    Just change the version number in the download link.
  5. priestjim

    priestjim Well-Known Member

    Thank you for your prompt response! I've downloaded the new version and tested it and it works however I get some strange behavior. Normally, LSWS should parse the extra-docroot .htaccess on-the-fly, on par with the actual .htaccess files inside the docroot but it doesn't, it requires a graceful restart in order to read the extra-docroot .htaccess file (which is what I was trying to avoid in the first place-lsws restarting for a single .htaccess file change).
  6. mistwang

    mistwang LiteSpeed Staff

    Just touch the .htaccess inside the docroot, it will reload both htaccess file, no need to restart the server.
  7. priestjim

    priestjim Well-Known Member

    What you suggested works, but what if the user deletes the .htaccess in docroot? I've tried it and the .htaccess outside docroot stops getting read! Outside the docroot I can control the .htaccess's permissions and force some options without intervening with the user's own .htaccess (which is almost always overwritten by most CMSes, BB software etc that use their own).

    Thanks for the effort anyway!
  8. mistwang

    mistwang LiteSpeed Staff

    should have take care of the missing .htaccess under docroot scenario in the latest 4.0.3 build. You can give it a try.
  9. priestjim

    priestjim Well-Known Member

    OK, now it works, but it doesn't work when I want to set a general .htaccess file for all domains and subdomains in a Plesk domain (something that Apache does). That means that /var/www/vhosts/ applies on /var/www/vhosts/ but not on /var/www/vhosts/
  10. anything

    anything Well-Known Member

    sorry to resurrect an old topic, I've only just realized that this is happening to me.

    document root is /var/www/website/html/
    /var/www/website/html/.htaccess is checked
    /var/www/website/.htaccess is not

    ive checked using filesystem inotify, its not even read at all.

    also tried adding an explicit AllowOverride All for /var/www/website inside the virtualhost in case something else was disabling overrides.

    Ive tested on 4.1.1, 4.1.3 and 4.1.4.

    I am very concerned that it is not working some websites are password protected this way, now they are not!

    can you tell me how to get this to work?
  11. mistwang

    mistwang LiteSpeed Staff

    LiteSpeed does not go though the whole directory hierarchies looking for .htaccess like Apache, which low efficient.
    LiteSpeed will look up to the document root of the vhost, and the user's home directory, if it is a subdomain, it look up to one directory level up, which usually is the document root of the main domain.
    Moving configurations into .htaccess under document root is preferred.

Share This Page