.htaccess doesn't work

Discussion in 'Install/Configuration' started by dredy, Mar 5, 2006.

  1. dredy

    dredy New Member

    .htaccess doesn't work on my server.
    I tried all "HT Access > Allow Override" options for both of "Server" and "Virtual Host" but doesn't work. And there is not any error logs.. Do you have an idea?
    p.s.: that .htaccess files are correctly work on Apache
  2. mistwang

    mistwang LiteSpeed Staff

    You can turn on debug logging by setting "debug level" to "high" and "log level" to "debug", activity on .htaccess should be in the log file.

    Remember to restart the server after the configuration changes.

    Maybe the directives in the .htaccess that you expect to work are not supported by LSWS yet.
  3. dredy

    dredy New Member

    i tried it but there is not any error log about protected directory in error_log file. there is only this log in access_log:

    [06/Mar/2006:01:29:32 +0200] "GET /_xxxxz/ HTTP/1.1" 304 - "-"
    .htaccess file has got read permission for all users
    it contains following lines:

    AuthType Basic
    AuthName "Access Denied"
    AuthUserFile "/home/xxxx/public_html/admin/.passwd"
    require valid-user

    HT Access Edit
    Allow Override N/A
    Access File Name .htaccess

    [THIS VHOST'S SECTION]: (X: checked)
    HT Access Edit
    Allow Override X Limit X Auth X FileInfo X Indexes X Options None
    Access File Name .htaccess
    I already tried with all unchecked

    what's the problem?
  4. mistwang

    mistwang LiteSpeed Staff

    Server level configuration is 'N/A', which disables .htaccess for the whole server. it must be turned on at server level in order to enable .htacess for any vhost.

Share This Page