If you have Problems with Admin Interface and Firefox Stylesheets

Discussion in 'Bug Reports' started by ripkens, Dec 18, 2007.

  1. ripkens

    ripkens Member

    Go to $SERVER_ROOT/admin/html/classes/ws and edit GUI.php

    Change around line ~10 HTML 4.01 in HTML 4.0

    Styles will be loaded again...

  2. mistwang

    mistwang LiteSpeed Staff

    Are you sure it should be "4.0" instead of "4.01"?
    I think it should not affect the stylesheets, if you upgrade from earlier version, you may have to reload the stylesheet as previous version is cached by the browser.
  3. ripkens

    ripkens Member

    Yes iam sure,

    i have 6 Litespeedservers running and all of them had the same effect.

    And for Gecko Quirks mode, 4.0 will use the mime type on the css link, 4.01 will overide the mime type by the server mime type wich is obviously set to text/html.

    If you would add mime.properties to admin area, it could be handled, if you would allow .htacces in admin area, it could be handled.

    You do not support both, so the only way is to enable Gecko quirks mode by setting the DTD to 4.0.
  4. xing

    xing LiteSpeed Staff


    Not sure why you have problems with our css style sheets in Firefox.

    Here is the css response header output form the webui admin:

    Date	Wed, 19 Dec 2007 19:04:26 GMT
    Server	LiteSpeed
    Accept-Ranges	bytes
    Connection	Keep-Alive
    Keep-Alive	timeout=5, max=100
    Etag	"1d53-475e47f7-259006e"
    Last-Modified	Tue, 11 Dec 2007 08:19:03 GMT
    Content-Type	text/css
    Content-Length	2222
    Content-Encoding	gzip
    Vary	Accept-Encoding
    Cache-Control	max-age=86400
    Expires	Thu, 20 Dec 2007 19:04:26 GMT
    Content type is correctly sent as text/css.
  5. ripkens

    ripkens Member

    Iam upgrading one of our 6 servers to 3.3.4.

    It doesnt load the StyleSheets in FF, IE and Opera.

    Even Changing the DTD to 4.0 to enable Quirks mode doesnt help.

    What could i do to get the Stylesheets working?
  6. ripkens

    ripkens Member

    OMG, it is a total mess. I probably have to reinstall the whole server.
    Upgrading from 3.2.4 to any newer version leads into non working stylesheets and JS.

    Therefore, i can not downgrade anymore.
    Tried to compile new php 5.2.5 with lsws web interface.

    It worked almost. New php version became active. eAccelerator failed because of missing directories (/usr/local/lsws/bin/lsphp5/phpize does not exist)

    php5 cli reports broken modules.
    Cronjobs not running anymore because of this.

    PHP Warning: PHP Startup: Unable to initialize module
    Module compiled with module API=20020429, debug=0, thread-safety=0
    PHP compiled with module API=20060613, debug=0, thread-safety=0
    These options need to match
    in Unknown on line 0
    PHP 5.2.5 (cli) (built: Feb 5 2008 12:38:47)
    Copyright (c) 1997-2007 The PHP Group
    Zend Engine v2.2.0, Copyright (c) 1998-2007 Zend Technologies
    with Zend Extension Manager v1.2.0, Copyright (c) 2003-2007, by Zend Technologies
    with Zend Optimizer v3.2.8, Copyright (c) 1998-2007, by Zend Technologies

    Reinstalled php 5.2.5, doesnt change anything.

    I have no clue what is causing this mess.
    I gonna reinstall the complete thing now and see what happens...
  7. mistwang

    mistwang LiteSpeed Staff

    some PHP modules does not match the current PHP verison, so, you need to rebuild your extra PHP modules as well, like memcache, etc.
  8. ripkens

    ripkens Member

    Same Problem

    I have reinstalled the whole server

    3.3.4 is now running without problems
    PHP4 and PHP5 also

    And now FF wont show stylesheets.

    Changed admin/html/classes/ws/GUI.php line 10 "HTML 4.01" into "HTML 4.0"

    Now it worls in IE and FF

    So you definetly get FF problems when its set to 4.01

    I guess it wont hurt if you change that in the next update to make sure FF uses quirks mode wich is only when it is NOT set to 4.01
  9. mistwang

    mistwang LiteSpeed Staff

    OK, will do.

Share This Page