Install Help!

Discussion in 'Install/Configuration' started by Styles, Jun 17, 2008.

  1. Styles

    Styles Member

    Hey, I have a VPS server and am currently trying to install the enterprise version. If this works out, I want to buy a license. :) This is crazy fast (Friend has it).

    Now, I have installed the latest version of it. I have it installed in /usr/src/lsws-3.3.14/

    Now, it installed fine BUT pages and open directorys are BLANK. Only HTML pages work! >< I hate this! So, I've tried to compile my own php and it doesn't work!

    The errors I am getting are:
    And during compiling I get:
  2. mistwang

    mistwang LiteSpeed Staff

    Maybe you need to change gcc's permission mask temporarily to "0755"

    ls -l /usr/bin/gcc

    chmod 0755 /usr/bin/gcc

    after finish compiling, change it back.
  3. Styles

    Styles Member

    Hello sir, thanks for responding, sorry that didn't work. Same error.

  4. mistwang

    mistwang LiteSpeed Staff

    You need to check the config.log under lsws/phpbuild/php-5.2.6 directory to find out what exactly is the error for gcc.
  5. Styles

    Styles Member

    Ok the error log is : I didn't find anything.. besides what I showed you.

    nvm: Error:

    Last edited: Jun 17, 2008
  6. mistwang

    mistwang LiteSpeed Staff

    You should do the same permission fix for "ld" as well.
  7. Styles

    Styles Member

    That fixed it thanks

Share This Page