Install on CentOS5.5, Plesk, need to work with vBulletin

Discussion in 'Install/Configuration' started by Alan_SP, Mar 31, 2011.

  1. Alan_SP

    Alan_SP Member

    I tried to build PHP version to 5.3.6, but it didn't worked out. Now I'm compiling PHP again to 5.2.17. Why is this problem? I thought that PHP for Litespeed and Apache are completely separated.

    Anyway, I hope that it will work out now when I'm back to 5.2.17...
  2. Alan_SP

    Alan_SP Member

    I'll note it down. Anyway, it worked out without --with-mysqli at all.

    How can I try to manually create my vhost with Plesk supported, I know there's only one site, in only one directory. What should I put and where in vhost file configuration?
  3. NiteWave

    NiteWave Administrator

    I meant you don't need install plesk at all, litespeed + vBulletin will work well. since you do need Plesk, so Plesk + trial license litespeed + vBulettin will be the easiest way to go.

    usually, user setup Plesk + apache + app and make them working, then install litespeed which will read and parse apache's httpd.conf, build lsphp, then stop apache and start litespeed. all virtual hosts configuration are through Plesk + apache.

    this wiki page is for the detail steps:
    How to replace Apache with LiteSpeed when used with Plesk
    Last edited: Apr 2, 2011
  4. Alan_SP

    Alan_SP Member

    Now I get all working up again (well, not the Plesk configuration), even replaced apache completly. Plesk is still working on its own port, but you say that virtual host configuration is through Plesk and apache? How it works when I stopped apache?
  5. NiteWave

    NiteWave Administrator

    apache, litespeed, Plesk all have a common configuration file:
    (this is in case of Plesk, in cPanel it's /usr/local/apache/conf/httpd.conf)
    so even apache stop, but leave a working httpd.conf there, litespeed can understand it well and make it working properly.
  6. Alan_SP

    Alan_SP Member

    So, now I have Plesk working with Litespeed? I just looked at processes at Plesk and it sees apache running. Anyway, I think that for now everything works just fine, only thing is xcache admin panel, it doesn't work (but it didn't worked right on apache too, I'm confused, I think it worked before, not sure really, on working server it works).

    I'll later try to modify some things in Plesk and see if it gets reflected in Litespeed even if it didn't imported configuration.

    I need Plesk to configure my DNS, FTP, mail, also protection of files etc... So I would need Litespeed to work with it. Anyway, when I decide to really transfer my working server to Litespeed, I'll buy license, now I'm just testing to see how it works and what I should do to make it right.

    Please, how can I upgrade PHP version? As I said, I didn't manage to have 5.3.6 successfully compiled, I need to downgrade to 5.2.17, as it's version I have running with apache.
  7. NiteWave

    NiteWave Administrator

    litespeed admin console:)7080)
    -->Compile PHP
    select php version here.
  8. Alan_SP

    Alan_SP Member

    Yes, but you haven't read all I wrote here.

    I did that, upgraded to PHP 5.3.6 and it didn't worked. Why? I don't know. I needed to downgrade to PHP 5.2.17 and it works now again, as I tested upgradeing to PHP 5-3-6. I have PHP 5.2.17 as mod for Apache.
  9. NiteWave

    NiteWave Administrator

    if vBulletin working with php 5.3.x, it will work with lsphp5 + litespeed.

    need check the error log for more detail.
    first check if phpinfo() page work?
    then vBulletin home page. if not work, any message in server's error log?
  10. Alan_SP

    Alan_SP Member

    Ok, maybe I'll test it later, but as far as I know, vBulletin works with 5.3.6.

    So, it should work, having different version of PHP in Litespeed and Apache?

    Oh yes, I had phpinfo saying that I'm running 5.3.6, but didn't get vBulletin to work. I'll need to check error log next time when I try this. Main thing is, it works on Litespeed. :)
  11. NiteWave

    NiteWave Administrator

  12. Alan_SP

    Alan_SP Member

    Excellent, I'll need that link you just gave me for my use later. :)

    When I try again to upgrade to PHP 5.3.6, I'll look in error log and see what's there. Main thing is that vBulletin works with PHP 5.2.17.

    This customer, what PHP he had with Apache?

Share This Page