Install on mimimal debian system.

Discussion in 'Install/Configuration' started by Da-Idiot, Feb 25, 2005.

  1. Da-Idiot

    Da-Idiot Member

    I cannot seem to get the lshttpd to stay running. Each time i give the "./lswsctrl start" command from within" /opt/lsws/bin/" it says it started but i do not see it when I run top.

    The only process i see related to lsws is" lscgid" and each time i try to stop and restart with the lswsctrl script it just spawns another "lscgid" but lshttpd does not run.

    I have tried deleting the /etc/lshttpd/ directory and all other trouble shooting steps in the documentation.

    I am running the latest version of lsws.

    Also I tried to apt-get install glibc-2.2 but it did not install and said

    Selecting libc6 instead, Which is already installed.

    The install procedure seemed to go ok. And i have tryed reinstalling twice now.

    I am installing as root and running the commands from a remote box using ssh

    Any help in getting this running will be of great help. Thanx

    Another note.

    I had it running on suse 9.2 but have just switched to debian because i could not do away with its package management apt-get as i run a command line box only. No gui

    Any help please.
  2. mistwang

    mistwang LiteSpeed Staff

    Any thing in lsws/logs/error.log?
  3. Da-Idiot

    Da-Idiot Member

    My mind is fried :shock:

    It says

    2005-02-24 18:23:07.327 [NOTICE] Loading LiteSpeed/2.0RC7 Standard ...
    2005-02-24 18:23:07.331 [NOTICE] [ADMIN] server socket:
    2005-02-24 18:23:07.331 [NOTICE] Loading configuration from /opt/lsws/conf/httpd_config.xml ...
    2005-02-24 18:23:07.332 [INFO] old priority: 0, new priority: 0
    2005-02-24 18:23:07.332 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2005-02-24 18:23:07.334 [NOTICE] The maximum number of file descriptor limit is set to 1024.
    2005-02-24 18:23:07.337 [NOTICE] [AutoRestarter] new child process with pid=926 is forked!
    2005-02-24 18:23:07.339 [NOTICE] [AutoRestarter] child process with pid=926 received signal=11, no core file is created!
    2005-02-24 18:23:07.339 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets belong to process 926 !
  4. Da-Idiot

    Da-Idiot Member

    To low a pid ?
  5. mistwang

    mistwang LiteSpeed Staff

    I think it is a binary/library compatibility issue.
    Try starting lsws as the normal user specified during the installation, just run lsws/bin/lshttpd directly.

    Also, you need to change a configuration file manully, lsws/admin/conf/admin_config.xml , search for some thing like <enableCoreDump>, set it to 1.

    If it creates a core file under /tmp/lshttpd/, please send the core file to

    I will take a look tomorrow. :)
  6. Da-Idiot

    Da-Idiot Member


    I changed the coredump setting to 1 and saved the file.

    Then i ran "lshttpd &" directly but still no go. Got the same errors as before with the new process ids.

    I also checked the /tmp/lshttpd folder for a core dump file but all that is there is the pid file.

    This really stinks because i love your server when i was running it on suse.

  7. mistwang

    mistwang LiteSpeed Staff

    Did you start it as root or as the normal user? have to be a normal user.
    Which version of debian are you using?
  8. Da-Idiot

    Da-Idiot Member

    I just tried to start it as a normal user, No Go


    Cannot determine the home of lite speed web server, exit!
    Failed to start lshttpd

    Can you please remind me the command to see what version of software I am running? I beleive I am running 3.0 of debian.

    Hope I can get this running.
  9. Da-Idiot

    Da-Idiot Member

    Latest error log
    2005-02-27 05:30:57.652 [ERROR] [config:vhost:Example] Path is in the access denied list:/etc/lsws/DEFAULT/html/
    2005-02-27 05:30:57.652 [ERROR] [config:vhost:Example] configuration failed!
    2005-02-27 05:30:57.653 [NOTICE] [AutoRestarter] new child process with pid=6273 is forked!
    2005-02-27 05:30:57.655 [NOTICE] [AutoRestarter] child process with pid=6273 received signal=11, no core file is created!
    2005-02-27 05:30:57.655 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets belong to process 6273 !
  10. Da-Idiot

    Da-Idiot Member

    Just tried reinstalling to the default location. /opt/lsws

    Now going back to forked process.

    2005-02-27 05:36:58.974 [NOTICE] Loading LiteSpeed/2.0RC7 Standard ...
    2005-02-27 05:36:58.978 [NOTICE] [ADMIN] server socket:
    2005-02-27 05:36:58.978 [NOTICE] Loading configuration from /opt/lsws/conf/httpd_config.xml ...
    2005-02-27 05:36:58.979 [INFO] old priority: 0, new priority: 0
    2005-02-27 05:36:58.979 [INFO] [config:server:basic] For better obscurity, server version number is hidden in the response header.
    2005-02-27 05:36:58.982 [NOTICE] The maximum number of file descriptor limit is set to 1024.
    2005-02-27 05:36:58.985 [NOTICE] [AutoRestarter] new child process with pid=6757 is forked!
    2005-02-27 05:36:58.986 [NOTICE] [AutoRestarter] child process with pid=6757 received signal=11, no core file is created!
    2005-02-27 05:36:58.986 [NOTICE] [AutoRestarter] cleanup children processes and unix sockets belong to process 6757 !
  11. mistwang

    mistwang LiteSpeed Staff

    Do not install lsws under /etc, it is not allowed to serve anything under /etc for security reason.

    If you don't mind and your server is available over internet, I'd like to logon your server and take look. It is the best way I can help right now. PM me. Up to you. :)
  12. Da-Idiot

    Da-Idiot Member

    Referring to my initial post

    I tried deleting the


    Directory, not the etc/lshttpd directory.
    Sorry for the misunderstanding.

    I sent you a pm regarding the access to server. Let me know whaen you want to do that and i will set you up.

    Thanx for the help.
  13. mistwang

    mistwang LiteSpeed Staff

    The problem is identified. It is due to the 2.2.x kernel used on that server. 2.4.x kernel is the minimum requirement of LSWS. :)

Share This Page