Install redis in Php 8.0.11 (Compiled, not OS packages)

I am struggling with installing redis module in php 8.0.11 with litespeed enterprise version.

Steps I did:

Compiled PHP - works
Download phpredis, extracted tgz

./configure  --with-php-config=/usr/local/lsws/lsphp8/bin/php-config
make install
Then i saw the module in the path:

ls  /usr/local/lsws/lsphp8/lib/php/extensions/no-debug-non-zts-20200930/
I added extension to php.ini

Restart lshttpd and ran a phpinfo() and still no redis loaded..

Am I missing something?

I manually downloaded pecl and installed it too and it build redis the same but it wouldn't load when built that way.

Is there an option to add it to compile time when building php? --with-redis doesn't seem to do squat
So, I noticed if i run php -i from the shell, it loads the correct php.ini and I see redis module loaded - but for some reason, when running lsphp from litespeed, its showing no php.ini is loaded and i've restarted, i've set the PHPRC to the path - it looks like it should be looking at the right section as it says this:

Configuration File (php.ini) Path/usr/local/lsws/lsphp8/lib
Loaded Configuration File(none)
Scan this dir for additional .ini files(none)
Additional .ini files parsed(none)

Any tips on how to get the litespeed process to load right php.ini that does exist in the config path?