Inventory index LiteMage purged tags not purged

#1
Hi

I’m getting the following error when trying to run an index job on Magento

---
Inventory index <!DOCTYPE html>
<html style="height:100%">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1, shrink-to-fit=no" >
<title> 414 Request-URI Too Large
</title></head>
<body style="color: #444; margin:0;font: normal 14px/20px Arial, Helvetica, sans-serif; height:100%; background-color: #fff;">
<div style="height:auto; min-height:100%; "> <div style="text-align: center; width:800px; margin-left: -400px; position:absolute; top: 30%; left:50%;">
<h1 style="margin:0; font-size:150px; line-height:150px; font-weight:bold;">414</h1>
<h2 style="margin-top:20px;font-size: 30px;">Request-URI Too Large
</h2>
<p>The request URL is over the maximum size allowed!</p>
</div></div></body></html>
---

It kept saying this when I reindexed

---
Inventory index LiteMage purged tags cat_p_2710,cat_p_2709,cat_p_2708,cat_p_2707 ,cat_p_2706,cat_p_2702,cat_p_2699,cat_p_2697,cat_p_2698,cat_p_2701,cat_p_2700,ca t_p_2704,cat_p_2712,cat_p_2703,cat_p_2711,cat_p_2705,cat_p_2639,cat_p_2640,cat_p _2641,cat_p_2642,cat_p_2643,cat_p_2647,cat_p_2650,cat_p_2539,cat_p_2536,cat_p_25 43,cat_p_2545,cat_p_2565,cat_p_2544,cat_p_2547,cat_p_2652,cat_p_2653,cat_p_2651, cat_p_2655,cat_p_2656,cat_p_2657,cat_p_2658,cat_p_2659,cat_p_2660,cat_p_2661,cat _p_2662,cat_p_2663,cat_p_2664,cat_p_2665,cat_p_2666,cat_p_2667,cat_p_2668,cat_p_ 2669,cat_p_2670,cat_p_2671,cat_p_2672,cat_p_2673,cat_p_2674,cat_p_2675,cat_p_251 8,cat_p_2517,cat_p_2519,cat_p_2521,cat_p_2520,cat_p_2523,cat_p_2522,cat_p_2525,c at_p_2524,cat_p_2529,cat_p_2528,cat_p_2527,cat_p_2526,cat_p_2533,cat_p_2532,cat_ p_2534,cat_p_2531,cat_p_2530,cat_p_2690,cat_p_2691,cat_p_2692,cat_p_2693,cat_p_2 695,cat_p_2696,cat_p_2694,cat_p_2687,cat_p_2686,cat_p_2685,cat_p_2684,cat_p_2688 ,cat_p_2689,cat_p_2548,cat_p_2546,cat_p_2541,cat_p_2635,cat_p_2581,cat_p_2582,ca t_p_2587,cat_p_2535,cat_p_2634,cat_p_2633,cat_p_2542,cat_p_2553,cat_p_2538,cat_p _2557,cat_p_2556,cat_p_2644,cat_p_2645,cat_p_2646,cat_p_2648,cat_p_2649,cat_p_27 15,cat_p_2716,cat_p_2714,cat_p_2713,cat_p_2595,cat_p_2654,cat_p_2676,cat_p_2677, cat_p_2679,cat_p_2680,cat_p_2678,cat_p_2681,cat_p_2682,cat_p_2683,cat_p_2628,cat _p_2604,cat_p_2608,cat_p_2605,cat_p_2607,cat_p_2606,cat_p_2616,cat_p_2617,cat_p_ 2618,cat_p_2550,cat_p_2540,cat_p_2549,cat_p_2583,cat_p_2580,cat_p_2585,cat_p_258 6,cat_p_2584,cat_p_2597,cat_p_2598,cat_p_2599,cat_p_2596,cat_p_2601,cat_p_2602,c at_p_2603,cat_p_2600,cat_p_2592,cat_p_2613,cat_p_2612,cat_p_2614,cat_p_2615,cat_ p_2552,cat_p_2537,cat_p_2554,cat_p_2555,cat_p_2631,cat_p_2632,cat_p_2629,cat_p_2 630,cat_p_2589,cat_p_2590,cat_p_2591,cat_p_2593,cat_p_2594,cat_p_2551,cat_p_2564 ,cat_p_2588,cat_p_2569,cat_p_2570,cat_p_2567,cat_p_2568,cat_p_2566,cat_p_2571,ca t_p_2636,cat_p_2637,cat_p_2638,cat_p_2573,cat_p_2574,cat_p_2575,cat_p_2572,cat_p _2577,cat_p_2578,cat_p_2579,cat_p_2576,cat_p_2559,cat_p_2558,cat_p_2560,cat_p_25 61,cat_p_2562,cat_p_2563,cat_p_2609,cat_p_2611,cat_p_2610,cat_p_2620,cat_p_2624, cat_p_2621,cat_p_2625,cat_p_2623,cat_p_2627,cat_p_2622,cat_p_2626,cat_p_2619
has been rebuilt successfully in 00:00:03
---

Which, by my understanding, happen once but that purged tags line keeps getting bigger until it gives that error of 414.

Any idea?
 
#4
A bit of background:

The issue only started once I did a "Transfer Inventory To Source" on certain products (e.g transferred inventory quantities from one source to another).
 

Pong

Well-Known Member
Staff member
#5
I don't see any problem on LiteMage side from the log. The tags are generated by Magento itself, not by LiteMage. maybe your "transfer inventory to source" introduces a lot of changes to your products. You can try to temporarily disable LiteMage before you do such transaction and enable litemage back after your reindex.
 
#6
If I put "Built-in Cache" for Full Page Cache and run the following commands then everything works without errors.

Code:
bin/magento index:reindex && bin/magento c:f
Capture.PNG

Re-enabling Litespeed Full Page Caching and running the above commands throws out the error.

Error.PNG
 

Pong

Well-Known Member
Staff member
#8
Can you log a ticket with us by providing tmp ssh login and you magento admin login for us to check?
 
Top