Ioncube doesn't work

Discussion in 'General' started by optize, Mar 12, 2010.

  1. optize

    optize Well-Known Member

    phpinfo() states Ioncube is loaded, however when we try to run scripts related to Ioncube, it states:

    Site error: the file /home/xx/public_html/converge/install/index.php requires the ionCube PHP Loader to be installed by the site administrator.

    It's loaded in php.ini;

    # cat /usr/lib/php.ini | grep

    If I switch back to apache, it works.... So I'm running out of options.

    Any ideas?
  2. optize

    optize Well-Known Member

    I upgraded to the latest php 5.2.x branch and re-built the Litespeed PHP binary.

    No go.

    I can run the index.php file from the command line;

    # php index.php
    <html><head><title>IPS Driver Error</title>
    <style>P,BODY{ font-family:arial,sans-serif; font-size:11px; }</style></head><body>
    <blockquote><h1>IPS Driver Error</h1><b>There appears to be an error with the database.</b><br>
    You can try to refresh the page by clicking <a href="javascript:window.location=window.location;">here</a>

    Litespeed still doesn't like it.
  3. optize

    optize Well-Known Member

    I created a customized php.ini file in that users directory ;

    zend_extension = /usr/local/ioncube/

    Which fixed it, there must be another php.ini file somewhere that litespeed is reading that doesn't have the ioncube definition in it.
  4. mistwang

    mistwang LiteSpeed Staff

    You can check the php.ini search path from phpinfo() output and put php.ini there.

Share This Page