Issue with symbolic links?

Discussion in 'Install/Configuration' started by vanne, Apr 28, 2007.

  1. vanne

    vanne New Member

    Is there an issue with symlinks in the latest version (3.0.3) of Litespeed ? For some reason when I try to add a new virtual host under the EasyRailsWithSuEXEC template, it gives me the following error:

    Warning: is_dir() []: Stat failed for /home/www/rails/my_app/current (errno=13 - Permission denied) in /opt/lsws/admin/html.3.0.3/classes/ConfValidation.php on line 571
    and on top of the VH input:

    *path /home/www/rails/my_app/current does not exist. Please create manually.
    the path : /home/www/rails/my_app/current points to a symlink created by capistrano, this worked with previous versions of LS and now for some odd reason it doesn't seem to work.

    It works fine when I point the VH to a standard directory. I thought it was a permissions issues so I checked the permissions and I even chmod 755 -R on the whole directory just to make sure and it still didn't even work. Any help would be appreciated.


  2. mistwang

    mistwang LiteSpeed Staff

    Have you checked the permission of the symbolic link itself as well as its parent directories?
  3. vanne

    vanne New Member

    I just set 755 permissions on all directories and the symlink in there and it is still giving me those issues. Think I should just downgrade?
  4. mistwang

    mistwang LiteSpeed Staff

    You can try downgrade, but I think it will not help.
    It still looks like a permission issue to me, you can try something like
    sudo -u <user_lshttpd_run_as> ls /home/www/rails/my_app/current
    See what do you get.:)
  5. vanne

    vanne New Member

    I get :

    /bin/ls: /home/www/rails/my_app/current/: Permission denied
  6. vanne

    vanne New Member

    I Figured out the problem, I had set my deploy_to path in my cap recipe to a symlink'd path within my user path that I use when logged in via ssh. So when trying to 'ls' on the deployed path with the lsws_user it would deny permission, I simply changed the deployed path to the absolute path without any symlinks involved and it worked! Thanks for your help anyways I really appreciated it.

Share This Page