JS files were not compressed when compressing through Gzip

I tried many solutions to resolve the problem of js files were not compressed anymore while compressing through gzip but nothing works.

FYI, i just been using the LSWS Enterprise 1-CPU Owned and apache server configuration loaded here to support apache configuration paramaeters.

Followed solutions were,

1. http://www.litespeedtech.com/support/forum/threads/gzip-not-compressing-js-files-as-per-yslow.4274/
2. http://www.feedthebot.com/pagespeed/enable-compression.html
3. http://stackoverflow.com/questions/...n-not-compressing-js-css-in-other-directories
4. http://stackoverflow.com/questions/...ssion-deflate-js-and-css-files-not-compressed
5. http://www.litespeedtech.com/suppor...-javascript-vs-js-application-javascript.3964

Please guide me through the right path to get this problem solved.

if you would like to see the uncompressed js files then please go through here http://gtmetrix.com/reports/www.bucketfeet.com/p8LUkiBL and here you will see the lot of js files listed as not compressing. please let me know what could be the cause of js file not compressing.
Last edited:


yes, in chrome access:

Response Header:
HTTP/1.1 200 OK
Date: Fri, 18 Jul 2014 01:39:21 GMT
Server: LiteSpeed
Accept-Ranges: bytes
Connection: Keep-Alive
Keep-Alive: timeout=5, max=100
Last-Modified: Tue, 17 Jun 2014 09:55:03 GMT
Content-Type: text/javascript
Content-Length: 72174

but css is gzip'd.

1. is lsws latest version -- 4.2.12 ?
2. what's your current setting of
lsws web admin->Server->Tuning->Compressible Types
3. some directives in .htaccess may override the default setting.
just copy skin/frontend/default/bucketfeetnew/js/jquery-1.4.2.min.js to document root, see if gzip or not
1. My Current LSWS version is 4.2.12
2. Please find the attachment for Compressible types
3. Actually i can't make it because if i make any change in the default functions that may affect my site and fyi, i have placed the same files in same location in the another server (skin/frontend/default/bucketfeetnew/js/jquery-1.4.2.min.js) but that works great as expected( see here "http://gtmetrix.com/reports/") that was not having litespeed web server instead running under apache server. please let me know what would be the case in litespeed web server configuration.



LiteSpeed Staff
The problem might be fixed already.
You only have "application/x-javascript" defined in MIME setting, but "text/javascript" MIME is used in the response. Adding the matfching MIME type will fix the compression problem.
for application/x-javascript mime suffix added as js and for application/javascript suffix as js2 so what should i add for text/javascript as ?. in mime properties please let me know.
Hi There,

Gzip compression was not working after upgrade my lsws version to latest 4.2.18 but if i switch back to 4.2.17 then it works. so what would be the cause gzip not working in latest lsws version?


LiteSpeed Staff
Please force reinstall 4.2.18 with command
/usr/local/lsws/admin/misc/lsup.sh -f -v 4.2.18

if problem persists, please let us know how to check the problem.