Komento and LiteSpeed Cache Plugin

Discussion in 'LiteSpeed Cache Extension for Joomla' started by rahg0zar, Oct 11, 2018.

Tags:
  1. rahg0zar

    rahg0zar Member

    I can't post comment with komento when LiteSpeed Cache Plugin enable and not logged-in;
    komento also added to Exclude Components.
    get this error:
    Code:
    Status: 200
    Status Text: parsererror
    Response Text: Invalid token
     
    Last edited by a moderator: Oct 12, 2018 at 1:59 PM
  2. Wuhua Chen

    Wuhua Chen Member Staff Member

    The komento component should have some module (comment module in this case) have a hidden token field with varied token value for different user.
    Please try set komento component related module (comment module) to ESI module, then set the ESI Module Type to "private"
     
  3. Wuhua Chen

    Wuhua Chen Member Staff Member

    You may set ESI Module Type to "none", because sometimes "private" ESI module not work for some 3rd party modules. Thanks.
     
  4. rahg0zar

    rahg0zar Member

    There isn't any komento component related module!
     
  5. Wuhua Chen

    Wuhua Chen Member Staff Member

    I may need more information to locate the problem. can you give me a download link of the komento component? You can join our slack community and "joomla-cache" channel , we can give you live support.
     
  6. rahg0zar

    rahg0zar Member

    I'm using this version: https://ufile.io/r82pv
     
    Last edited by a moderator: Oct 15, 2018 at 2:06 PM
  7. Wuhua Chen

    Wuhua Chen Member Staff Member

    Thanks, I checked the komento component, it is using a plugin to generate comment area html souce code, our current cache plugin version do not support it. I will submit an update tomorrow to support this component tomorrow, thanks for your patient.
     
  8. rahg0zar

    rahg0zar Member

  9. Wuhua Chen

    Wuhua Chen Member Staff Member

    I submitted an update for this type of issue, you can download and install the latest package from GitHub to solve it. Thanks.
     
  10. rahg0zar

    rahg0zar Member

    Same error with this version.
     
  11. Wuhua Chen

    Wuhua Chen Member Staff Member

    This version pass the test in my local site with the komento component you gave me, Can you email me your website information to wchen@litespeedtech.com , it will be better if I can have a back end admin login account.
     
  12. rahg0zar

    rahg0zar Member

    I sent you my website information.
    Thank you.
     

Share This Page