Litespeed 4.0.16 (4.0.15) terrible slow ! Why ?

Discussion in 'Install/Configuration' started by perikleus, Aug 20, 2010.

  1. perikleus

    perikleus New Member

    Hi Guys,
    we are Litespeed customers for about two years now and have currently 3 VPSs running with 4.0.15 Version of litespeed.
    Yesterday we upgraded one server to 4.0.16 and faced the problem of very slow loading websites ... !!
    Even a switch back to the 4.0.15 version was a solution ... slow page loading.
    We switched to apache and it was instantly up to 5 times faster !

    We tried about all solutions mentioned here in the forum:

    • MySQL optimization and repair (which speeded up also the sites now under Apache server)
    • php rebuilding (we running 5.2.14, 5.3.x is not an option yet)
    • PHP suEXEC Max Conn changed to 20 or 25
    • suexec off
    • eaccelerator on and off
    • /tmp folder check (type and if it is full)

    Nothing helps ... !!

    The VPS has by far enough resources with 8-cores and 4GB guaranteed ram for about 120 client accounts.
    We can not find the issue here!

    Also there is no error log in /usr/local/lsws/logs .... only access.log and a ap_cmd_param.log which shows nothing unusual ! :confused:

    The error.log from /usr/local/lsws/admin/logs shows us:

    Please help us the server is in production and the clients are busy ... !!
  2. NiteWave

    NiteWave Administrator

    so your server run cPanel. the error log file is /usr/local/apache/error_log. any messages in it?
  3. perikleus

    perikleus New Member

    Yes it is a Cpanel Server .... sorry, I forgot to mention this ...

    the file /usr/local/apache/logs/error_log shows a huge number of entries like this ...

    ... for the time Litespeed was running !
  4. perikleus

    perikleus New Member

    The Litespeed server is also switched to 4-core licence 2 weeks ago ... I don't know if this information matters ?!
  5. mistwang

    mistwang LiteSpeed Staff

    Have you notice anything abnormal when LiteSpeed is slow? high CPU utilization? high load? memory usage?
    If you run LiteSpeed on another port parallel to Apache, the page load is low on another port?
  6. mistwang

    mistwang LiteSpeed Staff

    Those are not log entries produced by LiteSpeed, but Apache.
  7. dimmis

    dimmis Active Member

    The memory usage raised to 30% or up to 50% sometimes ... load stays always < 1 !!
    The check on another port we did not checked yet .... !
    We needed to fix the situation quickly for our customers ... but as mentioned before, even the downgrade back to 4.0.15 did not fixed the problem .... !
    So we replaced the /usr/local/lsws folder with a backup from before the update to 4.0.16 and it worked !
    The 4.0.15 now is running normal fast now ... but we will not update now because our customers will be angry !!

Share This Page