LiteSpeed ignoring custom index files

Discussion in 'Bug Reports' started by bobykus, Dec 14, 2012.

  1. bobykus

    bobykus Well-Known Member

    v4.2.1

    Index Files index.html, index.php, index.php5, index.htm, hostedby.php


    Go to


    http://some.dk/


    get


    Index of /

    Name Last modified Size Description

    cgi-bin 10-Nov-2012 00:10 -
    cp 10-Nov-2012 00:10 -
    hostedby.php 10-Nov-2012 00:10 1k
    images 10-Nov-2012 00:10 -
    index.html.in.surftown 10-Nov-2012 00:10 4k
    login.html 10-Nov-2012 00:10 4k
    robots.txt 10-Nov-2012 00:10 1k
    webalizer 13-Dec-2012 23:21 -

    Why?
     
  2. mistwang

    mistwang LiteSpeed Staff

    Maybe index override in .htaccess was disabled.
    Try switching back to Apache temporarily, see if you get the same result.
     
  3. bobykus

    bobykus Well-Known Member

    What is "index override in .htaccess was disabled"?
    It is set in admin>configuration>server>Index Files>Index Files
    In admin>configuration>server>HT Access>Allow Override all is set to yes
    The only .htaccess in user home is force of php 5.2 use

    # cat /some/.htaccess
    #-------------------------
    # To use php5.3 comment this out
    AddType application/x-httpd-php52 php52 php
    #-------------------------

    What exactly I have to check for? The option to switch to Apache is
    wrong - more then 2k vhosts is on the server, no downtime allowed.
     
  4. bobykus

    bobykus Well-Known Member

    Ah, OK - here is the answer.
    DirectoryIndex in apache conf file is more important then litespeed one.
    Strange...
     

Share This Page