Litespeed is using APC beta

Discussion in 'PHP' started by anything, Oct 8, 2010.

  1. anything

    anything Well-Known Member


    Im converting to litespeed because running with suexec its the fastest webserver by far.
    And i used the litespeed's php compiler/etc thingy to build php 5.2.14 with no real problems.

    However some of the sites started having some strange issues, mostly related to when apc.include_once_override is enabled it was causing wordpress sites to error with: "Call to undefined function wp_dashboard_setup".

    I discovered it is because litespeed's php compiler used a beta version of APC (3.1.3p1) instead of the stable version (3.0.19).
    Compiling the stable APC version myself and restarting the php processes instantly solved the problems on all the sites involved.

    I admit that the stable version is rather old, and the beta version of APC seems 'good enough' when you do some quick tests.
    But I think its important that there should be lots of red text and popups and warnings and notices when something wants to use beta software for a 'professional high performance webserver'
    Last edited: Oct 8, 2010
  2. NiteWave

    NiteWave Administrator

    can you upgrade to 4.0.17 and rebuild php? it uses APC 3.1.4

    this looks the first report we received regarding APC 3.1.3p1 not working with WP well. and we have selected APC version higher than 3.0.19 for a long time. that's why we don't stick to 3.0.19.

    thanks for the report. We may change the APC build way if confirmed with it.
  3. anything

    anything Well-Known Member

    Ill give it a go when I get a chance

    I actually found heaps of similar wp error reports online. But nobody seemed to figure out that the actual cause was APC.
    They were all making changes to wordpress's php scripts to get around it only to suffer random module issues afterwards.
  4. anything

    anything Well-Known Member

    I gave the latest litespeed and apc 3.1.4 a go last week when i upgraded some servers.
    Again - I comment that litespeed gave no option to use a STABLE version

    with this new version things went horribly wrong.
    inconsistent and random strange stuff happening all over the place.
    as well as "unable to allocate memory for pool" at random times.
    sorry i have nothing specific for you, i assume depending on their state the different processes of php were behaving slightly differently to each other

    but same as last time, this was instantly solved by rolling back to a stable version of APC.
    perhaps it something specific about our config

Share This Page