Litespeed plugin for Opencart 3.0.x

#1
Hi Litespeed

First, thank you for this Litespeed Cache Extension.

I was using the version 1.0.2 and i was not really happy with this extension, because some layouts, designs was missing after i enabling the LSCache extension.
Now, the latest version 1.1.0 is much more better. the designs are to 99% correct, some small things are missing, in my custom opencart theme,.

My question is, and i dont know if you can help, when i use the litespeed cache, my cart is not updating correctly, because the javascripts that are being cached?

Currently no javascript files are cached, but litespeed does that? Possible to exclude some javascript from cache?
 

Jon K

Administrator
Staff member
#2
The cache plugin should not cache any Javascript files as they are static. Are you using Enterprise LiteSpeed or OpenLiteSpeed?
 
#3
i got the same "problem" when i use the module "litespeed" in htaccess with <ifModule Litespeed>
is it the php files and not javascript? Since i disabled the browser cache for javascripts in htaccess, the cart is working fine and always correct.
but when i use caching, i got again the cart issue.

The HTTP-Header shows "Server: LiteSpeed", and i think my webhosting uses also enterprise litespeed and not OpenLiteSpeed. does that help?
 

Pong

Well-Known Member
Staff member
#4
As Jon adviced, LiteSpeed doesn't cache static files, such as javascripts.

Browser cache issue is nothing to do with LiteSpeed cache. They are different caches.

Do you use any CDN service, such as CloudFlare? CDN may also cause static file cache problem. Do you use any javascritp minifier?

For better understanding:
Which line you have disabled for browser cache for Javascript in htaccess?
 
#5
Hi Pong

no, we dont use any CDN-Services, and we dont use any javascript minifier.
I do not understand why it occurs again with litespeed cache. if it's not on the litespeed cache, then we can close this topic.

in htaccess we use the following to disable javascript browser cache, and since then, the cart is working fine. i think we have a cache issue but we cant solve it. with litespeed cache, the website is much more faster, but we have then the cart issue :-/ maybe it is an individual case

<IfModule mod_expires.c>
ExpiresActive on
ExpiresDefault "access plus 1 month"
# JavaScript
ExpiresByType application/javascript "access plus 0 seconds"
ExpiresByType text/javascript "access plus 0 seconds"
</IfModule>

thank you for your support guys
 

Pong

Well-Known Member
Staff member
#6
Their directives are browser cache configuration and nothing to do with LiteSpeed full page cache. LiteSpeed cache only caches dynamic contents and does not cache static files (js files, images, css files etc) at all by design.

Looks like the browser cache break the checkout somehow. Since it is not LiteSpeed cache related, we may not be able to provide any recommendation or fix to it. The checkout plugin developer may know better than us why it breaks.

If there is any other issue related to LiteSpeed cache, please kindly let us know and we are more than happy to assist you.
 
Top