LSCache plugin for Joomla! 4 and administration errors


I'm using several sites Joomla! 4.2.9 with the latest LSCache plugin for J4.
With the standard .htaccess rules, the test with failed, so a support technician from my hosting provider added this line in the .htaccess
CacheEnable public /
Now the test gives a positive result.

But when I try to access the administration, I log in but the page remains the login page, as if I were not logged in, without error.
I need to add for example "index.php" to access the control panel.
Then when I log out, the page is not the login page but the previous page.
I tried to exclude "connection" and "control panel" menu links in the component's options, and "/administrator" as URL, but it does not work, the problems in the administration remain.

If I deactivate that line, I have no more problems in the administration, but checking fails "LSCache is not supported".
I didn't find how to have a good checkind AND a functional administration management.

Could you help me? Thanks!

That line was added by the support of my host.
I uninstalled the plugin and installed the last version for J4 and all works fine now. Only this code is in the .htaccess
<IfModule LiteSpeed>
CacheLookup on
I think you did'nt understand.
I was using the previous version of LSCache plugin for Joomla! 4 and had an error on a Virtuemart website. The plugin was corrected and I updated it. Then said LSCache was not active.
My host added CacheEnable public / (added to CacheLookup on) in the .htaccess and checking the site was positive. But lors of problems in te administration.
So I uninstalled the plugin and installed the latest version and all works fine, check and administration.
I think the update had a problem, not a first installation.


Well-Known Member
You are the first user to complain about the standard code that the plugin writes in the .htaccess. This leads to the conclusion that in your case there must be other reasons why the standard code you stated would not have worked.

FYI: The code your hoster put in is correct, but it's only used when using the cache function without a plugin.