Magento 2 - LiteMage Cached Objects always 0

Discussion in 'LiteMage Cache Extension For Magento' started by Ian, Apr 16, 2017.

  1. Ian

    Ian New Member

    Hi,

    I have installed litemage 2 on our magento 2.
    Under system -> Cache Management -> LiteMage Cached Objects
    The number is always 0. This means litemage is not caching anything.
    upload_2017-4-16_16-0-15.png

    On your page, you mentioned that running the command below at /app and /vendor.
    grep -r cacheable * | grep xml | grep false
    I have changed all xml files with cacheable="false" to cacheable="true" in the app folder subdirectories.
    However, if you run the above command in /vendor folder, there is a long list including those magento default modules with cacheable="false" and tons of javascript.
    Please see below.
    upload_2017-4-16_15-58-24.png

    How is it possible to change these to cacheable="true"?
    Is there something that I have done incorrectly that makes litemage cacheable objects always zero?

    Please help.

    Thank you.
    Ian
     
  2. Lauren

    Lauren LiteSpeed Staff Staff Member

    Ian,
    You cannot simply change cacheable=false to true. You need to examine which plugins are doing that for default handle. If it's in default.xml, then it affects all page. You need to check for that plugin, why it has that setting. If you change cacheable=true, it may break the plugin functionality. So you should either not use that plugin, or understand the consequence of changing it. You can also try to ask that plugin developer, why it sets that way.
    Lauren
     
  3. Ian

    Ian New Member

    Hi Lauren,

    Is there any way to bypass this setting and force litemage to cache? Are you able to do this setting in the next magento module release?
    It is very difficult to troubleshoot which plug in causes this.
    If we have this setting, we can enable litemage cache and see if it's causing any problems. If no problem, then great!

    Thank you.
    Ian
     
  4. Lauren

    Lauren LiteSpeed Staff Staff Member

    There's no way for litemage plugin to not honor other people's config.
    Code:
    grep -r cacheable * | grep 'default.xml' | grep false
    You only need to check those in default.xml, and check which plugin. you can either change to "true" or disable that plugin.
     
  5. Ian

    Ian New Member

    We still can't get this to work. I do not understand why Magento normal file cache, Fastly CDN cache are able to cache full page but litemage is not able to cache.
    Instead of following the rules cacheable="false", why not give us an option to add/remove url that exempted from caching.
    For example sucuri and cloudflare (by pagerules) has options for us to key in the url that should not be cached.
     

Share This Page