Max request body size

Discussion in 'Install/Configuration' started by hkirste, Feb 27, 2013.

  1. hkirste

    hkirste Member

    The warning is gone, but the problem persists. I can't upload files > than 500 mb.
  2. NiteWave

    NiteWave Administrator

    please enable debug log(lsws admin console->Actions->Toggle Debug Logging) during upload, see if can capture useful info/error message
  3. hkirste

    hkirste Member

    [*.*.*.*:60836-0#APVH_Default] Request body size: 1073743096 is too big!
  4. NiteWave

    NiteWave Administrator

    I did tests on a local 32-bit x86 linux box, uploaded 1.2G file with succeed.

    if you're using php to handle the uploaded file, please check upload_max_filesize and post_max_size limit set in php.ini(you can refer

    if you set
    Max Request Body Size (bytes): 7G
    and has problem,
    please try
    Max Request Body Size (bytes): 7000M
    see if ok. then it's a bug and will fix it later.
  5. hkirste

    hkirste Member

    It's giving the same error as before.
    Theres no debug error logged for this one.

    My script is a CGI (Perl) script. I don't think it is CGI or PHP (if it was a php script) since it's telling that the body size is too big in a error from litespeed.

    Edit: Just tried with 2000M and seems to be working. Can you raise the limit to more, plese?
    Last edited: Mar 8, 2013
  6. NiteWave

    NiteWave Administrator

    just now reproduced the issue.
    on a x86_64 linux box, when set to 5000M, upload a 1.4G file failed;
    when set to 2000M, upload 1.4G succeeded.

    Has reported to development. Thanks!
  7. NiteWave

    NiteWave Administrator

    the latest build(4.2.2) has fixed the issue.
    I tested with php script many times, it's working now.
    will write a wiki later.

    during the testing, found a php issue as well:
    to upload file >2G, in php.ini
    must set to 0. if set to 3G etc, upload will fail.

Share This Page