Need help for a serious LSPHP config issue.

Discussion in 'Install/Configuration' started by sahith, Aug 8, 2018.

  1. sahith

    sahith Well-Known Member

    Hi, i have an Android application which gets its responses from api.php file. So if any user open the app all the required information will be loaded from api.php file. Usually my app has 60-100 online users anytime. and data in the app loads very fast for any number of random users. From the following picture you can see my WaitQ is always zero and req/sec stays around 1. And my server CPU stays around 6% usage.
    Capture3.JPG

    I use onesignal for push notifications. If i push any notification i get around 400-500 online users. This is where i get trouble. After push notification, all figures gets filled with some WaitQ, and CPU usage slightly increase to 10%.

    Capture.JPG

    Thats it. My app gets absolutely zero response until WaitQ is cleared. And all remaining sites in server works fine. Only this app account goes down.

    I wonder something has to do with my LSPHP configuration to handle all 400 users who are requesting api.php simultaneously. Below is my LSPHP configuration.

    Capture2.JPG

    I desperately need an expert advice to overcome this issue. Do increasing max connections help?
     
  2. Pong

    Pong Well-Known Member Staff Member

  3. sahith

    sahith Well-Known Member

    Cache is already there, But there are many dynamic responses. I am already using 80 for PHP SuEXEC Max Conn setting for this account, Do increasing them to 200-400 solve the issue? Do increasing PHP max connections solve the issue? Cause we are just getting many users accessing a single php file with different responses.
     
    Last edited: Aug 8, 2018
  4. Pong

    Pong Well-Known Member Staff Member

    Increase PHP SuEXEC Max Conn should give you more room to run since 80 already in the pool. You should keep in waitq to 0.
    what do you mean "Cache is already there, But there are many dynamic responses", sound like " I can not use cache since every user request is different" to me. If cache is really in use, you won't have much PHP processes at all.
     
  5. sahith

    sahith Well-Known Member

    So If the server can handle do increasing PHP SuEXEC Max Conn to 500, do any favor?
     
  6. NiteWave

    NiteWave Administrator

    is the notification's content is same to all users? if so, you can consider caching it, to avoid WaitQ > 0
     
  7. sahith

    sahith Well-Known Member

    Yeah, I can't cache that api.php file. Cause it serve different content for different users based on their requests. So my only concern is how can i reduce the WaitQ. Do increasing PHP SuEXEC Max Conn to 500, do any favor?
     
  8. NiteWave

    NiteWave Administrator

    you can try it. see if your server is ok with such load.
     

Share This Page